Bug 47869 - nmh should (optionally) use smtp not sendmail
nmh should (optionally) use smtp not sendmail
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: nmh (Show other bugs)
7.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Florian La Roche
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-08 12:48 EDT by John R MacMillan
Modified: 2007-04-18 12:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-21 04:32:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John R MacMillan 2001-07-08 12:48:54 EDT
Description of Problem:

The nmh package included with 7.1 uses sendmail directly
which impairs some of the functions of nmh. In particular
nmh allows the user varying levels of control over the
From: line (see mh-tailor(5)) but if sendmail is used as
the transport rather than SMTP, it puts in an authentication
warning that gives away the underlying user address.

This is undesirable in many environments where the raw
UNIX user name is not the official e-mail address, or where
people have multiple e-mail addresses and want to be able
to use different ones without giving another away.

Most e-mail clients these days use SMTP directly, including
other ones Redhat ships (eg. Netscape Communicator), and
7.1 ships with a local SMTP server enabled, so nmh should
be build to use this. If you're really worried about it,
provide two packages, say nmh-smtp and nmh-sendmail so
people can go either way.


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Trond Eivind Glomsrxd 2001-07-08 18:38:59 EDT
Filed against wrong component (Distutils) - reassigning.
Comment 2 Need Real Name 2001-07-09 07:32:33 EDT
I ran into this bug this morning, having upgraded yesterday from RH6.2 to
RH7.1; none of my outgoing e-mail is being delivered at the moment
because the "mts.conf" file that I restored from my RH6.2 system
is being ignored.

Specifically, the "post" backend-command in the RH7.1 distribution
seems to ignore the "servers" line in mts.conf - the line which in 
theory should direct the mail to be sent to my mailserver - and instead
seems to be hardwired to call /usr/lib/sendmail, try-as-I-might to dissuade it.

If the problem *is* due to a configuration option in the RH7.1 distribution,
then
I can trivially uninstall NMH and recompile it from scratch; that said, I would
prefer that the program still worked as documented in the manpages, and
indeed as used to be in RH6.*

Thanks,

Note You need to log in before you can comment on or make changes to this bug.