Bug 478691 - GIMP does not use poppler for PDF import due to missing dependency in .spec
GIMP does not use poppler for PDF import due to missing dependency in .spec
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-03 12:20 EST by Johan Vromans
Modified: 2009-01-14 21:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-14 21:58:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johan Vromans 2009-01-03 12:20:25 EST
Description of problem:

GIMP 2.6.3 (Fedora 10) does not use poppler for PDF import, even though it is compiled with --use-poppler. 

How reproducible:

Build and look for the output of configure. It reads something like "POPPLER: no (using Ghostscript plugin)"

Expected results:

"POPPLER: yes"

Additional info:

The problem is that configure (using pkgconfig) fails to find satisfactory information for poppler due to a missing file /usr/lib/pkgconfig/poppler-glib.pc. This file is part of the poppler-glib-devel package that is not part of the listed build requirements for Gimp.

Solution:

Add "BuildRequires: poppler-glib-devel" to gimp.spec.

Note: This works for Fedora 10 only, since that seems to be the first release to have a separate poppler-glib-devel kit.
Comment 1 Nils Philippsen 2009-01-07 05:35:01 EST
Fixed in gimp-2.6.4-3.fc10.

NB: F9 updates has poppler-glib-devel, too.
Comment 2 Fedora Update System 2009-01-07 05:37:46 EST
gimp-2.6.4-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gimp-2.6.4-3.fc10
Comment 3 Fedora Update System 2009-01-07 05:38:48 EST
gimp-2.6.4-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/gimp-2.6.4-3.fc9
Comment 4 Fedora Update System 2009-01-07 16:50:14 EST
gimp-2.6.4-3.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update gimp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-0301
Comment 5 Fedora Update System 2009-01-07 16:52:09 EST
gimp-2.6.4-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gimp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0265
Comment 6 Johan Vromans 2009-01-08 17:11:18 EST
Confirmed OK on F10 (don't have F9 around anymore).
Thanks!
Comment 7 Fedora Update System 2009-01-14 21:52:53 EST
gimp-2.6.4-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2009-01-14 21:58:37 EST
gimp-2.6.4-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.