Bug 478697 - RFE: Be able to find packages with NVR greater than that in repo(s)
RFE: Be able to find packages with NVR greater than that in repo(s)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
: FutureFeature, Patch
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-01-03 12:58 EST by Bruno Wolff III
Modified: 2014-01-21 18:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-29 08:43:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Script to show newer packages than are in rawhide (2.53 KB, text/x-python)
2009-01-04 13:52 EST, James Antill
no flags Details

  None (edit)
Description Bruno Wolff III 2009-01-03 12:58:53 EST
Description of problem:
Currently there have been some issues with packages having a higher NVR in F10 + Updates + Updates-testing than in rawhide blocking yum updates in ways that skip broken couldn't handle. Being able to easily find those packages would be useful. Using package-cleanup --orphans before the update will have too many false positives. After the update it works for clean up, but that doesn't help when the update is blocked and you need to figure out what might be blocking it.

What would be nice is to be able to point yum-utils at rawhide and then have it report any installed packages that have a higher NVR than the same package in the repo(s) it is pointed to. This would help focus fixing things on a small set of packages.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 James Antill 2009-01-04 13:52:28 EST
Created attachment 328149 [details]
Script to show newer packages than are in rawhide

I thougyht skvidal was working on something that did this with bodhi/koji trees, so we could tell things like "is anything in F9 newer than what is in F10" ... but anyway, this does what I think we/you want for current => rawhide.
On my F9 box it just gives:

% ../yum-newer-than-rawhide.py
Loaded plugins: post-transaction-actions
Newer Packages
xorg-x11-drv-mouse.x86_64                   1.3.0-2.fc9                installed


which seems to be true:

Installed Packages
xorg-x11-drv-mouse.x86_64            1.3.0-2.fc9                installed       
Available Packages
xorg-x11-drv-mouse.x86_64            1.3.0-1.20081222git.fc11   rawhide         
xorg-x11-drv-mouse.x86_64            1.3.0-2.fc9                fedora          
xorg-x11-drv-mouse-debuginfo.x86_64  1.3.0-2.fc9                fedora-debuginfo
Comment 2 James Antill 2010-04-29 18:47:14 EDT
Note that with the latest yum in rawhide you can now do:

yum distro-sync

...which will tell you what is "different" and will probably just dtrt. anyway if you hit yes.

Note You need to log in before you can comment on or make changes to this bug.