Bug 478704 - gcc optimize flag causes different program behaviour
gcc optimize flag causes different program behaviour
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-03 16:13 EST by Dov Grobgeld
Modified: 2009-12-18 02:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 02:28:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dov Grobgeld 2009-01-03 16:13:27 EST
Description of problem:

I downloaded a opengl source tutorial from http://nehe.gamedev.net/data/lessons/linuxsdl/lesson40.tar.gz and compiled it twice. The first time with the default Makefile as provided in the tarball. The program then worked as described in the tutorial, a simulation of a string fell down the ground and came to a standstill. I then edited the Makefile and replaced -g with -O2 and recompiled. When running the program the string never settled but instead I got chaotic motion. 

It thus appears that there is an optimization bug that causes numeric instability of this particualar program. 

Version-Release number of selected component (if applicable):

gcc-4.3.2-7.src.rpm

How reproducible:

Every time.

Steps to Reproduce:
1. wget http://nehe.gamedev.net/data/lessons/linuxsdl/lesson40.tar.gz
2. tar -xf lesson40.tar.gz
3. cd lesson40_linux_sdl
4. make
5. ./lesson40
6. perl -pi~ -e 's/-g/-O2/' Makefile
7. make clean
8. make
9. ./lesson40
  
Actual results:

The second run of lesson40 yields chaotic motion.

Expected results:

The second run of lesson40 should give identical result to the first run.

Additional info:
Comment 1 Michal Nowak 2009-08-14 10:09:11 EDT
I gave a look at this test case on every Fedora we support but on every particular one it looked the same -- rope settling down pixel by pixel. Can you still reproduce it? What about F-11/Rawhide? Can you make a OGV from the motion?
Comment 2 Bug Zapper 2009-11-18 05:38:42 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Bug Zapper 2009-12-18 02:28:41 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 4 Dov Grobgeld 2009-12-18 02:50:44 EST
I just tested it with Fedora 12 and it has been solved.

Note You need to log in before you can comment on or make changes to this bug.