Bug 478723 - Click "Move to new Hardware Pool" has no response when moving storage
Click "Move to new Hardware Pool" has no response when moving storage
Status: CLOSED WONTFIX
Product: Virtualization Tools
Classification: Community
Component: ovirt-server-suite (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Scott Seago
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-04 01:39 EST by Yolkfull Chow
Modified: 2011-06-21 13:19 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-21 13:19:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of this problem (99.71 KB, image/png)
2009-01-04 01:47 EST, Yolkfull Chow
no flags Details

  None (edit)
Description Yolkfull Chow 2009-01-04 01:39:52 EST
Description of problem:
Go to defult resource pool, go to "Storage" TabPage, choose a storage server and click "Move", in the popup window, there is none hardware pool listed although they are really exist. Moreover, click "Move to new Hardware Pool" has no response.

Version-Release number of selected component (if applicable):
0.96

How reproducible:
Everytime

Steps to Reproduce:
1. create couples of hardware pools
2. go to default resource pool, go to TabPage Storage, choose a storage server and click "Move"
3. in the popup window, check whether existed hardware pools are listing, try to click button "Move to new Hardware Pool"
  
Actual results:
Click "Move to new Hardware Pool" has no response, moreover existing hardware pools are not listed in the popup window.

Expected results:
Should be able to move storage server from default to newly created hardware pool, or move to existing hardware pools.

Additional info:
Comment 1 Yolkfull Chow 2009-01-04 01:47:20 EST
Created attachment 328124 [details]
screenshot of this problem
Comment 2 Jia Dong 2009-01-21 02:48:20 EST
Add some information:

1.It can "import from" but cannot "move to".
2.Create a new hardware pool named "HwPool".The move tab on "HwPool" doesn't work,too.Not only default hardware pool.Maybe it is bug of move function.
Comment 3 Jason Guiditta 2009-05-15 13:36:20 EDT
doing this gives me the error:
uninitialized constant HardwareController::Storage
Comment 4 Scott Seago 2009-05-22 12:55:04 EDT
I think the original reported error has long since been resolved, but this action is currently broken for another reason -- an incorrect classname was used for Storage in the controller.

Fix patch is here:

https://www.redhat.com/archives/ovirt-devel/2009-May/msg00195.html

Note You need to log in before you can comment on or make changes to this bug.