Bug 478725 - Tracker live results do not show in deskbar applet
Summary: Tracker live results do not show in deskbar applet
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: tracker
Version: 10
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Michel Alexandre Salim
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 476608 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-01-04 08:24 UTC by srh
Modified: 2009-02-20 23:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-02-20 23:49:53 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 571573 None None None Never

Description srh 2009-01-04 08:24:01 UTC
Description of problem:
In Fedora 9, the deskbar applet queried the tracker search tool database as
part of presenting its results. In Fedora 10, under 'Deskbar Preferences',
Tracker is not available to tick as a wanted loaded extension. The ability is
access Tracker from deskbar applet is very useful.

The following files are installed on this Fedora 10 computer as part of normal
package installation:
/usr/lib/deskbar-applet/modules-2.20-compatible/tracker-module.py
/usr/lib/deskbar-applet/modules-2.20-compatible/tracker-module.pyc
/usr/lib/deskbar-applet/modules-2.20-compatible/tracker-module.pyo


Version-Release number of selected component (if applicable):
Name       : deskbar-applet
Arch       : i386
Version    : 2.24.1
Release    : 2.fc10

Name       : tracker
Arch       : i386
Version    : 0.6.6
Release    : 3.fc10

How reproducible:
Always

Steps to Reproduce:
1.Install tracker and deskbar-applet
2.Look for tracker extension under 'Deskbar preferences'
3.No can find.

Expected results:
Use Tracker results within deskbar-applet.

More info:
This is a duplicate bug report of Fedora bugzilla bug 476608, as I'm not sure which package (deskbar-applet or tracker) is bug belongs too and I haven't had a reply to the other bug report yet. Feel free to mark the appropriate bug report redundant, whichever package this bug doesn't apply to.
https://bugzilla.redhat.com/show_bug.cgi?id=476608

Also info about this bug at:
https://bugs.launchpad.net/ubuntu/+source/deskbar-applet/+bug/271925

Running deskbar-applet at command line:

[stewart@sefton ~]$ /usr/lib/deskbar-applet/deskbar-applet -d -w

01-04 21:20:02 deskbar.core.ModuleLoader ERROR    Error loading the file: /usr/lib/deskbar-applet/modules-2.20-compatible/tracker-module.py.
01-04 21:20:02 deskbar.core.ModuleLoader ERROR    problem in /usr/lib/deskbar-applet/modules-2.20-compatible/tracker-module.py - <type 'exceptions.ImportError'>: No module named gnomedesktop
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/deskbar/core/ModuleLoader.py", line 98, in import_module
    mod = pydoc.importfile (filename)
  File "/usr/lib/python2.5/pydoc.py", line 256, in importfile
    raise ErrorDuringImport(path, sys.exc_info())
ErrorDuringImport: problem in /usr/lib/deskbar-applet/modules-2.20-compatible/tracker-module.py - <type 'exceptions.ImportError'>: No module named gnomedesktop

Comment 1 Michel Alexandre Salim 2009-02-13 00:43:22 UTC
Confirmed; a fix is simply to replace one line in tracker-module.py to import gnomedesktop instead of deskbar.core.gnomedesktop.

Reported upstream, and a patched build will be available soon.

Comment 2 Michel Alexandre Salim 2009-02-13 00:44:00 UTC
*** Bug 476608 has been marked as a duplicate of this bug. ***

Comment 3 srh 2009-02-20 23:48:49 UTC
The following two packages have been installed from updates, and appear to fix the problem. Thanks. Closing bug.

tracker-0.6.6-4.fc10.i386
tracker-search-tool-0.6.6-4.fc10.i386


Note You need to log in before you can comment on or make changes to this bug.