Bug 478739 - Deleted storage server is still listing in storage page
Deleted storage server is still listing in storage page
Status: CLOSED WONTFIX
Product: Virtualization Tools
Classification: Community
Component: ovirt-server-suite (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Scott Seago
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-04 09:06 EST by Yolkfull Chow
Modified: 2014-07-06 15:31 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-21 13:20:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot of this problem (114.56 KB, image/png)
2009-01-04 09:06 EST, Yolkfull Chow
no flags Details

  None (edit)
Description Yolkfull Chow 2009-01-04 09:06:22 EST
Created attachment 328134 [details]
screen shot of this problem

Description of problem:
After deleting a nfs storage server in storage page, the server is listing in the page still although the tip message have shown delete successfully.

Version-Release number of selected component (if applicable):
0.96-1

How reproducible:
Everytime

Steps to Reproduce:
1. add a nfs storage server and a iSCSI server
2. delete the nfs storage
3. 
  
Actual results:
The nfs storage server is still listing in the page.

Expected results:
The nfs server should disappear immediately after deleting successfully.

Additional info:
Comment 1 Jia Dong 2009-01-21 03:12:48 EST
I can not reproduce it and can get the expected results.
Could you please give more information?
Comment 2 Hugh Brock 2009-05-22 14:02:19 EDT
I believe this is fixed, Ian can you verify? Had to do with broken db-omatic.
Comment 3 Ian Main 2009-05-27 18:55:55 EDT
mmm.. dbomatic doesn't deal with any kind of storage systems, only VMs.  The deletion of a pool does not have a corresponding event in taskomatic.  He may have meant a volume, which if it was never created properly (pending_setup state) we weren't deleting properly in taskomatic.  This was fixed a few months ago.
Comment 4 Ian Main 2009-05-29 12:34:06 EDT
OK, I'm seeing this bug too.  I have an NFS server configured with multiple volumes under it.  I can't delete it.  There are no VMs running.  This would be a UI/controller bug since taskomatic doesn't deal with deleting pools.  Not sure who to assign it to though.

Note You need to log in before you can comment on or make changes to this bug.