Bug 478752 - update verilog-mode .el
update verilog-mode .el
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Novotny
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-04 11:20 EST by Chitlesh GOORAH
Modified: 2009-01-06 06:28 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-05 17:18:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chitlesh GOORAH 2009-01-04 11:20:19 EST
Description of problem:
Can you please update emacs package and verify whether the verilog-mode.elc version is the latest ?
http://www.veripool.org/wiki/verilog-mode/Installing

If not, upstream should be ping for its update.


Version-Release number of selected component (if applicable):
rpm -qf /usr/share/emacs/22.2/lisp/progmodes/verilog-mode.elc
emacs-common-22.2-5.fc9.i386

thanks
Comment 1 Jonathan Underwood 2009-01-04 11:41:43 EST
Emacs 22.3 has been pushed as an update for F-10, but as yet not F-9.

Question is, is the version of verilog.el included with Emacs 22.3 the latest? Probably not. The problem is, once we start going down the route of updating lisp packages included with the emacs tarball with their respective upstream latest versions we have a big maintainence problem: MANY packages that are bundled with emacs are also maintained with separate upstreams eg. gnus, org-mode etc. If we start updating from the versions bundled with upstream Emacs, then we're losing all the integration and stability testing that is done and are starting to fork Emacs. 

If this is very important, the right approach IMO would be a separate emacs-verilog package which packages the latest verilog package from verilog upstream.
Comment 2 Chitlesh GOORAH 2009-01-05 17:18:51 EST
Hello,

No, it is that important. Since, I'm trying to give maximum support for electronics, I've filed this bug report.

Just contact upstream to update it in their next release, in case they haven't done so.

thanks.
Comment 3 Jonathan Underwood 2009-01-06 06:28:24 EST
I suggest you contact the verilog author and ask him to push his latest stable version to Emacs, or contact the Emacs developers and get them to pull the latest verilog.el. This isn't the sort of activity that is limited to package maintainers, and you're probably in a better position to comment on the stability of the latest release of verilog.el if you make use of it.

Note You need to log in before you can comment on or make changes to this bug.