Bug 478840 - multilib patch was removed, but multilib stopped working
multilib patch was removed, but multilib stopped working
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libtool (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-05 10:26 EST by Michal Hlavinka
Modified: 2009-02-19 14:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-18 07:23:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Hlavinka 2009-01-05 10:26:04 EST
Description of problem:
In Fedora 10 libtool wasn't using rpath for {/usr,}/lib64 directories, but now in rawhide with libtool 2.2, it does.

In F10 using autoreconf -f -i -v prevented libtool from using /usr/lib64 as rpath, now it's not working.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. try to make x86_64 for some package (for example ecryptfs-utils) with other rpath workarounds removed
2.
3.
  
Actual results:
rpmbuild fails because of /usr/lib64 rpath

Expected results:
libtool stops using {/usr,}/lib64 as rpath

Additional info:
Comment 1 Jason Tibbitts 2009-02-12 19:18:31 EST
Yes, this seems to be causing packages which did not have rpath issues in F10 to acquire them after a rawhide rebuild.  Maintainers are reticent to fix these because the problem is, ostensibly, in libtool.

It seems that some of the stuff patched by libtool-1.5.24-multilib.patch is still present in its unpatched form in the current libtool 2.2.6 tree, but honestly I don't know enough about libtool to tell what part of the source is the actual libtool and which is the libtool-generated configure bits used to build it.
Comment 2 Karsten Hopp 2009-02-18 07:23:28 EST
please try again with libtool-2.2.6-10.fc11 and reopen this bug when the problem still exists.
Comment 3 Michal Hlavinka 2009-02-18 08:51:20 EST
(In reply to comment #2)
> please try again with libtool-2.2.6-10.fc11 and reopen this bug when the
> problem still exists.

works for me
Comment 4 Jason Tibbitts 2009-02-19 14:08:26 EST
Yes, I can verify that this is fixed.

Note You need to log in before you can comment on or make changes to this bug.