Bug 478855 - kvm-81-1.fc11.x86_64 is missing /usr/share/kvm/bios.bin, vgabios.bin, ...
kvm-81-1.fc11.x86_64 is missing /usr/share/kvm/bios.bin, vgabios.bin, ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kvm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On: 478663
Blocks: F11Alpha/F11AlphaBlocker
  Show dependency treegraph
 
Reported: 2009-01-05 12:41 EST by Tom London
Modified: 2013-01-10 00:00 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-08 06:08:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2009-01-05 12:41:23 EST
Description of problem:
[tbl@tlondon ~]$ rpm -q kvm
kvm-81-1.fc11.x86_64
[tbl@tlondon ~]$ rpm -ql kvm | grep bios
[tbl@tlondon ~]$ 

Running "qemu-kvm" fails with a complaint about missing bios.bin.

Copying bios.bin and vgabios*.bin from kvm-79-1.fc11.x86_64.rpm to /usr/share/kvm "makes this work for me".

Version-Release number of selected component (if applicable):
kvm-81-1.fc11.x86_64

How reproducible:
Every time.....

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jesse Keating 2009-01-06 09:41:51 EST
In theory it was supposed to not need those, according to the changelog.  I'm putting this on the Alpha tracker as I'd really like it to work for alpha.
Comment 2 Daniel Berrange 2009-01-06 11:48:44 EST
There's a mistake in the configure args, and this is compounded by the lack of explicit file listing in the RPM spec, so the missing BIOS files were never detected at build time. I'm building a fix very shortly....
Comment 3 Daniel Berrange 2009-01-06 12:10:03 EST
Patch is ready and committed to CVS.

Unable to build in rawhide due to utterly broken kernel headers bug 478663
Comment 4 Daniel Berrange 2009-01-08 06:08:29 EST
Built into kvm-81-2.fc11
Comment 5 Tom London 2009-01-08 09:45:04 EST
I can verify: kvm-81-2.fc11.x86_64 "works for me".

Thanks!

Note You need to log in before you can comment on or make changes to this bug.