This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 478859 - Org Chart passes Locator a CN rather than the DN
Org Chart passes Locator a CN rather than the DN
Status: CLOSED WONTFIX
Product: 389
Classification: Community
Component: UI - Org Chart (Show other bugs)
1.2.0
All Linux
low Severity low
: ---
: ---
Assigned To: Rich Megginson
Ben Levenson
:
Depends On:
Blocks: 389_1.3.0
  Show dependency treegraph
 
Reported: 2009-01-05 12:53 EST by jamesc
Modified: 2015-11-13 15:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-13 15:09:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description jamesc 2009-01-05 12:53:49 EST
Description of problem:

The Org Chart can be configured to support an external "locator" application (url-locator-base in config.txt).  However, the "org" application passes the locator a cn, which is not guaranteed to be unique within the directory.  As a result, the locator may locate the wrong person.  Could org be changed to pass the dn of the person to be located, rather than a cn?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

I believe the relevant lines of $FDS_BASE/clients/orgchart/bin/org are 1495-1515, in the function print_topmost_box().
Comment 1 Martin Kosek 2012-01-04 08:42:55 EST
Upstream ticket:
https://fedorahosted.org/389/ticket/107
Comment 3 Noriko Hosoi 2015-11-13 15:09:49 EST
Closing this bug due to moving to the trac system.

https://fedorahosted.org/389/ticket/107

Note You need to log in before you can comment on or make changes to this bug.