Bug 478878 - kernel fails to boot (Asus 900A with ext2 root relatime, no separate /boot)
kernel fails to boot (Asus 900A with ext2 root relatime, no separate /boot)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-05 15:02 EST by Matthew Woehlke
Modified: 2009-04-21 17:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-21 17:28:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Woehlke 2009-01-05 15:02:02 EST
Upon booting, the kernel fails to start with the message "mount: error mounting /dev/root on /sysroot as ext2: Invalid argument".

I don't know exactly at what kernel version this began appearing but it happens with 2.6.27.9-159 and at least one previous kernel. As a result, I am currently stuck on 2.6.27.5-117 (which does not have the problem).

Reproducible always.

My /etc/fstab looks like this (UUID values elided):
UUID=<blah> /         ext2   relatime        1 1
UUID=<blah> /home     ext2   relatime        1 2
tmpfs       /dev/shm  tmpfs  defaults        0 0
devpts      /dev/pts  devpts gid-5,mode=620  0 0
sysfs       /sys      sysfs  defaults        0 0
proc        /proc     proc   defaults        0 0
tmpfs       /tmp      tmpfs  size=30%        0 0
Comment 1 Matthew Woehlke 2009-01-05 16:58:44 EST
Hmm, apparently this is a duplicate of bug 430280. (If someone can confirm, please close this accordingly.)

How is it that three-year-old bugs are reopening?
Comment 2 Matthew Woehlke 2009-01-06 20:45:38 EST
...or it might be a duplicate of bug 475495; can't tell without further testing (which I can't do until I get some time to play with the machine in question)
Comment 3 Matthew Woehlke 2009-01-28 14:31:53 EST
I just did the following:

sed -i 's/norelatime/defaults/' /etc/fstab # actually used vim, but you get the idea
yum update kernel\*
mv /etc/fstab{.bak,} # i.e. undid the above mount option change
reboot

...and I was able to boot the new kernel. Hopefully that narrows down where the problem is.
Comment 4 Matthew Woehlke 2009-04-21 17:28:04 EDT
seems to be working with the latest mkinitrd

Note You need to log in before you can comment on or make changes to this bug.