Bug 478883 - Subversion fails to handle client certificates
Subversion fails to handle client certificates
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: neon (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-05 15:33 EST by Kevin L. Mitchell
Modified: 2009-12-18 02:30 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 02:30:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 480041 None None None Never

  None (edit)
Description Kevin L. Mitchell 2009-01-05 15:33:14 EST
Description of problem:

I have a subversion repository where I have limited access such that connecting clients must present a valid client certificate.  I can successfully browse the repository with Firefox on Fedora 10 once I import the appropriate client certificate.  However, subversion is unable to access the repository; a sample error message (with URL obscured) follows:

[klmitch@kev-mobile programming]$ svn update
svn: OPTIONS of 'https://xxx.example.com/svn/programming/trunk': Could not read status line: SSL error: Rehandshake was requested by the peer. (https://xxx.example.com)

This same thing worked fine from a different machine running FC8 (before I upgraded it to FC10).  My .subversion/servers file contains appropriate entries for the server in question, so I doubt that's the problem.

Version-Release number of selected component (if applicable):

subversion-1.5.4-3.x86_64

How reproducible:

None of my client certificate-secured subversion repositories can be accessed.

Steps to Reproduce:
1. Set up a client certificate-secured subversion repository.
2. Set up the subversion client to have the appropriate entries in .subversion/servers
3. Attempt to access the secured subversion repository.
  
Actual results:

The subversion client is unable to access the subversion repository.

Expected results:

Subversion should be able to access the repository.

Additional info:

A Google search on the error message turned up a Debian bug which is probably related.  The relevant URL is http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=480041.  The executive summary appears to be that subversion fails with this error if using libneon27-gnutls, but works fine if using libneon27, suggesting a gnutls bug or perhaps a libneon bug related to using gnutls.
Comment 1 Joe Orton 2009-01-30 08:01:27 EST
It looked like this is a gnutls bug but I didn't prove this conclusively, so at most it's a neon bug.
Comment 2 Dimitris 2009-02-03 11:59:12 EST
Hi,

I am willing to test ant rpms that fix/workaround this.
Comment 3 Lev Shamardin 2009-06-02 13:55:14 EDT
I confirm the same problem and I am willing to test any rpms that could fix this.
Comment 4 Robert Brown 2009-08-02 02:44:19 EDT
I can confirm this is a problem on a standard subversion repo with just a username+password. The repo is hosted on an SSL web server but does not use client certificates. Again in my case this worked fine on a Fedora 8 box with that subversion client but this one won't connect, and I get this:
svn: OPTIONS of 'https://svn.collab.net/repos/svn/trunk': could not connect to server (https://svn.collab.net)

It's the same error for every https/ssl repo. I just used that one as a trial. No network packets are sent as I started a sniffer trace, so this dies somewhere before it hits the wire.

Looks like the debian folks found and fixed this:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=531338

It seems to be resolved in a later release of neon.
Comment 5 Robert Brown 2009-08-02 02:44:52 EDT
Oh and I am on Fedora 11 with all of the latest updates as of today.
Comment 6 Robert Brown 2009-08-02 02:53:11 EDT
I can confirm that the neon in the latest development/rawhide bundle fixes this issue. The fix for me was:

wget http://mirrors.kernel.org/fedora/development/source/SRPMS/neon-0.28.5-2.fc12.src.rpm
rpm -i neon-0.28.5-2.fc12.src.rpm
rpmbuild -bb neon.spec
rpm -U neon-0.28.5-2.fc11.i586.rpm

The maintainer may want to consider updating the FC11 release of neon to this version.
Comment 7 Joe Orton 2009-08-03 03:47:30 EDT
Robert: if you're seeing this fixed in 0.28.5, it's a slightly different to that tracked here.

There are 0.28.5 packages on their way to stable updates:

https://admin.fedoraproject.org/updates/F11/FEDORA-2009-7680
Comment 8 Bug Zapper 2009-11-18 05:40:04 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bug Zapper 2009-12-18 02:30:11 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.