Bug 478884 - firefox error 203 unless run as root
firefox error 203 unless run as root
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
10
i686 Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-05 15:39 EST by Dzmitry
Modified: 2009-01-14 14:47 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-14 14:47:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dzmitry 2009-01-05 15:39:28 EST
Description of problem:
Firefox refuses to install new or update existing plugins unless run as root. After that it is necessary to run chmod in order to let the normal user use firefox normally

Version-Release number of selected component (if applicable):
Fedora 10: kernel 2.6.27.9-159.fc10.i686
Gnome 2: 2.24.2
Firefox 3: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.0.5) Gecko/2008121622 Fedora/3.0.5-1.fc10 Firefox/3.0.5

How reproducible:
whenever firefox suggests to update plugins, or I run the update manually, the packages are being downloaded, but fail to install with an error 203. Running firefox as root solves this problem

Steps to Reproduce:
1. Search for updated plugins
2. Wait for updates to download
3. Stare at message boxes with "Error 203"
  
Actual results:
Plugins fail to install/upgrade


Expected results:
Plugins succeed to install/upgrade


Additional info:
Comment 1 Martin Stransky 2009-01-14 07:46:09 EST
Which plugins do you have installed and fails to update?
Comment 2 Dzmitry 2009-01-14 14:47:53 EST
as far as i remember, any plugin would produce that result. the thing is, I've manually updated (via root, and changed permissions back to normal user) once, and yesterday I tried updating again - now everything works just fine. closed :)
sorry for inconvenience :)

Note You need to log in before you can comment on or make changes to this bug.