Bug 478891 - Please convert to new font packaging guidelines
Please convert to new font packaging guidelines
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: wqy-zenhei-fonts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Qianqian Fang
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11-new-font-rules F11Target
  Show dependency treegraph
 
Reported: 2009-01-05 16:16 EST by Nicolas Mailhot
Modified: 2009-02-14 07:54 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-12 00:32:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
updated spec file for wqy-zenhei-fonts (2.89 KB, text/plain)
2009-01-14 18:36 EST, Qianqian Fang
no flags Details

  None (edit)
Description Nicolas Mailhot 2009-01-05 16:16:24 EST
This bug has been filed because we've detected your package includes one or
several font files:

repoquery -C --repoid=rawhide -f '*.ttf' -f '*.otf' -f '*.pfb' -f '*.pfa' '*.ttc' --qf='%{SOURCERPM}\n' |sed -e 's+-[0-9.-]*\.fc[123456789]\(.*\)src.rpm++g'|sort|uniq

Unfortunately this script does not detect symlinks to other packages, so if
that's your case, you can close this bug report now.

Otherwise, you should know that:

— Fedora guidelines demand the packaging of fonts in a separate package (or
subpackage):
http://fedoraproject.org/wiki/Packaging/Guidelines#Avoid_bundling_of_fonts_in_other_packages

— our font packaging guidelines recently changed, and every package that ships
fonts must be adapted to the new templates available in the fontpackages-devel
package:
  –
http://fedoraproject.org/wiki/PackagingDrafts/Fonts_packaging_automation_(2008-11-18)
  – http://fedoraproject.org/wiki/Fedora_fonts_policy_packagehttp://fedoraproject.org/wiki/Simple_fonts_spec_templatehttp://fedoraproject.org/wiki/Fonts_spec_template_for_multiple_fonts

Please make your package conform to the current guidelines in rawhide (you can
use the fontpackages package in F9 or F10 to test, but only submit changes to
rawhide please).

If your package is not principaly a font package, depending on a separate font
package or subpackage is the prefered solution. If your application does not
use fontconfig you can always package symlinks to the files provided by the
font package and installed in the correct fontconfig directories.

It is preferred to create a font package or subpackage per font family, though
it is not currently a hard guidelines requirement (it may become before Fedora
11 is released). The definition of a font family is given on:
http://fedoraproject.org/wiki/Fonts_spec_template_notes/font-family

The new templates should make the creation of font subpackages easy and safe.

The following packages have already been converted by their packager and can
serve as examples:
❄ andika-fonts
❄ apanov-heuristica-fonts
❄ bitstream-vera-fonts
❄ charis-fonts
❄ dejavu-fonts
❄ ecolier-court-fonts
❄ edrip-fonts
❄ gfs-ambrosia-fonts
❄ gfs-artemisia-fonts
❄ gfs-baskerville-fonts
❄ gfs-bodoni-classic-fonts
❄ gfs-bodoni-fonts
❄ gfs-complutum-fonts
❄ gfs-didot-classic-fonts
❄ gfs-didot-fonts
❄ gfs-eustace-fonts
❄ gfs-fleischman-fonts
❄ gfs-garaldus-fonts
❄ gfs-gazis-fonts
❄ gfs-jackson-fonts
❄ gfs-neohellenic-fonts
❄ gfs-nicefore-fonts
❄ gfs-olga-fonts
❄ gfs-porson-fonts
❄ gfs-solomos-fonts
❄ gfs-theokritos-fonts
❄ stix-fonts
❄ yanone-kaffeesatz-fonts

If you have any remaining questions about the new guidelines please ask them
on:
fedora-fonts-list at redhat.com
Comment 1 Nicolas Mailhot 2009-01-11 10:20:45 EST
To help packagers manage the transition to the new guidelines, we've published the following FAQ

http://fedoraproject.org/wiki/Shipping_fonts_in_other_packages_(FAQ)
Comment 2 Nicolas Mailhot 2009-01-14 13:38:27 EST
FPC approved those two additional guidelines recently, please take them into account if you need to create or update a fonts package or subpackage:

– 2009-01-14: naming
http://fedoraproject.org/wiki/PackagingDrafts/Font_package_naming_%282009-01-13%29

— 2009-01-06: exact splitting rules
http://fedoraproject.org/wiki/PackagingDrafts/Font_package_splitting_rules_%282008-12-21%29

(packagers that can drop font files and just depend on an existing font package are not impacted)
Comment 3 Qianqian Fang 2009-01-14 18:35:05 EST
sorry for my delay in responding to this upgrade. I used to build all the packages from a FC6 machine, and it took me a while to set up everything on a F10 virtual machine. Now everything seems to be working fine.

I have a problem to compile my package (for example, wqy-zenhei-fonts) with the new spec file (attached later): "make i386" complains about missing "wqy-zenhei-fonts-0.8.34" folder, which I assume it is the definition of %{_fontdir}, right?

the upstream src file only extract a wqy-zenhei folder, as other font packages from wqy. they are not named based on fedora font packages. What do you suggest me to do to get around this?

thanks
Comment 4 Qianqian Fang 2009-01-14 18:36:09 EST
Created attachment 329052 [details]
updated spec file for wqy-zenhei-fonts

Let me know if this file makes sense to you.
Comment 5 Nicolas Mailhot 2009-01-15 03:28:50 EST
np, there are lots of packagers which have not started working on it yer

1. You do not need the 
%{_fontdir}/*.ttc line in %files

2. Do you actually need to declare the fonts in the legacy core fonts X11 system? If it's not 100% necessary life will be simpler without the fonts.scale bit

3. If you install multiple fontconfig file you must find an expression rpm accepts that can be used as argument to the -f call to %{fontconf} (generaly, using ?? or other rpm wildcards)

Also please test with "fontpackages-*-1.14" from rawhide
Comment 6 Qianqian Fang 2009-02-12 00:32:09 EST
new package was built in rawhide.
Comment 7 Qianqian Fang 2009-02-12 00:44:03 EST
Also, as I mentioned before, I set up a sub-project to complete Google's Droid Sans Fallback. In the past 3 months, we used our web-based application (demo http://wenq.org/demo/fontopia_droid_tutorial.htm) and completed all 4300+ missing Han glyphs in CJK basic (U4E00-U9FC3). In the past month, we have been doing the final review and are about to release a new font soon (named "WenQuanYi Micro Hei"). Micro hei is only 4M in size with high quality glyphs. I strongly recommend shipping this font with F11 (possibly default install for Chinese support).

The latest nightly-build of the font can be found at 
http://wenq.org/daily/microhei/wqy-microhei-0.2-nightlybuild.tar.gz

I will submit a new package request soon.
Comment 8 Qianqian Fang 2009-02-12 00:46:20 EST
sorry, the above comment meant to posted at Bug#476459.
Comment 9 Nicolas Mailhot 2009-02-14 07:54:14 EST
A new package request will be very welcome :p

Note You need to log in before you can comment on or make changes to this bug.