Bug 478905 - %post/%preun scripts can fail
%post/%preun scripts can fail
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-XML-SAX (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-05 17:22 EST by Ville Skyttä
Modified: 2009-04-28 09:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-28 09:15:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Don't let scriptlets fail (725 bytes, patch)
2009-01-05 17:22 EST, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2009-01-05 17:22:40 EST
Created attachment 328238 [details]
Don't let scriptlets fail

The %post and %preun scripts of perl-XML-SAX can exit with non-zero exit status and thus wreak havoc in rpm transactions.  Fix attached.

I'm undecided whether 2>/dev/null would be welcome (obviously before the "|| :") in both scriptlets, but I suppose I'd be slightly in favor of dropping it because the failure would indicate a quite exceptional case; your call.
Comment 1 Marcela Mašláňová 2009-04-28 09:15:04 EDT
I'd rather leave there /dev/null and also || :

One of my packages was failing on upgrade without /dev/null.

Note You need to log in before you can comment on or make changes to this bug.