Bug 478915 - Labtec Webcam freezes the kernel up to 2.6.27.
Labtec Webcam freezes the kernel up to 2.6.27.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i386 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-05 18:39 EST by Leonardo
Modified: 2009-04-16 08:41 EDT (History)
2 users (show)

See Also:
Fixed In Version: kernel-2.6.29.1-30
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-16 08:41:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonardo 2009-01-05 18:39:31 EST
Description of problem:
I can't use my Labtec Webcam on a Fedora box since I've upgraded to kernel 2.6.27. I know it appears as not tested here (http://moinejf.free.fr/webcam.html), but I'd like to use my webcam again on the newest kernel available for Fedora.

Version-Release number of selected component (if applicable):
9 and 10

How reproducible:
Always.

Steps to Reproduce:
1. On F9, follow the instructions described here (http://hansdegoede.livejournal.com/6317.html).
2. On F10, open Cheese and try to anything (photo or video) with the webcam.
3.
  
Actual results:
Kernel freezes.

Expected results:
See the image on screen.

Additional info:

dmesg:
usb 2-1: new full speed USB device using uhci_hcd and address 3
usb 2-1: configuration #1 chosen from 1 choice
gspca: probing 046d:0921
gspca: probe ok
usb 2-1: New USB device found, idVendor=046d, idProduct=0921
usb 2-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0

lsusb:
Bus 002 Device 003: ID 046d:0921 Logitech, Inc. Labtec WebCam

lsmod | grep gspca:
gspca_tv8532           13440  0 
gspca_main             21504  1 gspca_tv8532
videodev               32000  1 gspca_main
Comment 1 Leonardo 2009-01-09 06:36:39 EST
I can help you with more information about my hardware or doing anything to collect debug information. Say me what you want and I'll do it. The only thing I need is to use my webcam again. It was supported by the old gspcav1.
Comment 2 Leonardo 2009-02-09 08:28:45 EST
This is a big problema for me. My webcam was supported by the old gspca driver running on a kernel older than 2.6.27. With the new libv4l, it stopped to work and it's very important for me. I don't want to use Fedora 8 (unsupported) or another distro only to make my webcam work again. This is a kernel/libv4l/gspca problem, cause I can't make it work on Ubuntu 8.10.
Comment 3 Leonardo 2009-04-16 08:41:04 EDT
This problem doesn't occur anymore in kernel 2.6.29.1-30 available since yesterday on updates-testing repository.

Note You need to log in before you can comment on or make changes to this bug.