Bug 478927 - Review Request: globus-rsl - Globus Toolkit - Resource Specification Language Library
Review Request: globus-rsl - Globus Toolkit - Resource Specification Language...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Thomas Sailer
Fedora Extras Quality Assurance
:
Depends On: gpt 453848 453851
Blocks: 478928
  Show dependency treegraph
 
Reported: 2009-01-05 20:15 EST by Mattias Ellert
Modified: 2009-05-12 00:05 EDT (History)
3 users (show)

See Also:
Fixed In Version: 5.0-3.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-27 17:29:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
t.sailer: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Mattias Ellert 2009-01-05 20:15:12 EST
Spec URL: http://www.grid.tsl.uu.se/repos/globus/info/globus-rsl.spec
SRPM URL: http://www.grid.tsl.uu.se/repos/globus/fedora/10/src/SRPMS/globus-rsl-5.0-0.3.fc10.src.rpm

Description:
The Globus Toolkit is an open source software toolkit used for
building Grid systems and applications. It is being developed by the
Globus Alliance and many others all over the world. A growing number
of projects and companies are using the Globus Toolkit to unlock the
potential of grids for their cause.

The globus-rsl package contains:
Resource Specification Language Library

BuildRequires:	grid-packaging-tools
BuildRequires:	globus-common-devel >= 3
BuildRequires:	globus-core-devel >= 4

Based on the globus toolkit 4.2.1 release.
Comment 1 Mattias Ellert 2009-03-15 20:02:41 EDT
New version
- Added s390x as 64 bit arch
- Added comment documenting source
- Adapt to changes in the globus-core package

http://www.grid.tsl.uu.se/repos/globus/fedora/10/src/SRPMS/globus-rsl-5.0-0.5.fc10.src.rpm
http://www.grid.tsl.uu.se/repos/globus/info/globus-rsl.spec
Comment 2 Mattias Ellert 2009-04-17 09:45:25 EDT
Package updated due to new packaging guidelines
- Change defines to globals
- Remove explicit requires on library packages

http://www.grid.tsl.uu.se/repos/globus/info/new/globus-rsl-5.0-1.fc10.src.rpm
http://www.grid.tsl.uu.se/repos/globus/info/new/globus-rsl.spec

Draft packaging guidelines for Globus packages are now available:
http://fedoraproject.org/wiki/PackagingDrafts/Globus
Comment 3 Thomas Sailer 2009-04-18 13:54:06 EDT
$ rpmlint globus-rsl*
globus-rsl.i586: W: shared-lib-calls-exit /usr/lib/libglobus_rsl.so.2.3.0 exit@GLIBC_2.0
globus-rsl.i586: W: no-documentation
globus-rsl-devel.i586: W: no-documentation
4 packages and 1 specfiles checked; 0 errors, 3 warnings.

http://koji.fedoraproject.org/koji/taskinfo?taskID=1306958
Comment 4 Thomas Sailer 2009-04-18 14:00:17 EDT
Fedora review globus-rsl-5.0-1.fc12.i586.rpm 2008-04-18

(btw: the posted spec file and the spec file contained in the srpm are not
consistent)

+ OK
! needs attention

! rpmlint output (including the license file as doc gets rid of the no docs warning)
+ Package is named according to Fedora Package Naming Guidelines
+ Specfile name matches the package base name
+ Package follows the Fedora packaging guidelines
+ License meets guidelines and is acceptable to Fedora
  ASL 2.0
+ License matches the actual package license
! The package contains the license file
+ Spec file is written in American English
+ Spec file is legible
+ Upstream sources match sources in the srpm
the source repacking makes it impossible to compare md5sum's, thus:
$ diff -urN globus_rsl-5.0 globus_rsl-5.0-dl
reports no differences

+ Package scratch-builds
n/a ExcludeArch bugs filed
+ BuildRequires list all build dependencies
n/a %find_lang instead of %{_datadir}/locale/*
+ binary RPM with shared library files must call ldconfig in %post and
%postun
+ Does not use Prefix: /usr
+ Package owns all directories it creates
+ No duplicate files in %files
+ %files has %defattr
+ %clean contains rm -rf $RPM_BUILD_ROOT
+ Consistent use of macros
+ Package must contain code or permissible content
n/a Large documentation files should go in -doc subpackage
n/a Files marked %doc should not affect package
+ Header files should be in -devel
n/a Static libraries should be in -static
! Packages containing pkgconfig (.pc) files need 'Requires: pkgconfig'
+ libfoo.so must go in -devel
+ -devel must require the fully versioned base
+ Packages should not contain libtool .la files
n/a Packages containing GUI apps must include %{name}.desktop file
+ Packages must not own files or directories owned by other packages
+ %install begins with rm -rf $RPM_BUILD_ROOT
+ Filenames must be valid UTF-8
Comment 5 Mattias Ellert 2009-04-18 16:28:01 EDT
(In reply to comment #4)
> Fedora review globus-rsl-5.0-1.fc12.i586.rpm 2008-04-18
> 
> (btw: the posted spec file and the spec file contained in the srpm are not
> consistent)

Sorry about that. It seems I copied the last version of the SRPM to the server with the wrong name after the last update - so the previous one was not overwritten as I intended. The difference between the versions was that I added globus-common as a Requires so that the package Requires a package that owns the direcories where it puts its files. I have updated the SRPM with the intended one. The specfile was the intended one.

> + OK
> ! needs attention
> 
> ! rpmlint output (including the license file as doc gets rid of the no docs
> warning)

I just removed the license file as doc in this version since a reviewer of a different package strongly argued that it shouldn't be there since it is not part of the source tree for this package (see bug 467235 comment 3). I really need all the packages to be the same, otherwise it is not maintainable. If you strongly disagree with the previous reviewer, I will try to do some arbitration.

> ! The package contains the license file

See above.

> ! Packages containing pkgconfig (.pc) files need 'Requires: pkgconfig'

globus-xio-devel Requires globus-core, which Requires pkgconfig.
Comment 6 Mattias Ellert 2009-04-18 16:36:11 EDT
(In reply to comment #5)
> > ! Packages containing pkgconfig (.pc) files need 'Requires: pkgconfig'
> 
> globus-xio-devel Requires globus-core, which Requires pkgconfig.  

cut and paste error - the argument is still true though:

globus-rsl-devel Requires globus-core, which Requires pkgconfig.
Comment 7 Mattias Ellert 2009-04-21 10:24:16 EDT
The conclusion of the thread on the fedora-packaging mailing list initiated in order to resolve the issue

https://www.redhat.com/archives/fedora-packaging/2009-April/msg00042.html

was that the license file must be part of the package. The thread also concluded that the license file must be copied into and made part of the extracted tarfile and not be a separate source file.

The package has been updated accordingly (including adding the cp command to the source generation description comment):

http://www.grid.tsl.uu.se/repos/globus/info/new/globus-rsl-5.0-2.fc10.src.rpm
http://www.grid.tsl.uu.se/repos/globus/info/new/globus-rsl.spec
Comment 8 Thomas Sailer 2009-04-21 12:51:13 EDT
APPROVED by sailer
Comment 9 Mattias Ellert 2009-04-21 13:41:37 EDT
Thank you for the review.


New Package CVS Request
=======================
Package Name: globus-rsl
Short Description: Globus Toolkit - Resource Specification Language Library
Owners: ellert
Branches: F-9 F-10 F-11 EL-4 EL-5
InitialCC:
Comment 10 Kevin Fenzi 2009-04-21 15:44:05 EDT
cvs done.
Comment 11 Fedora Update System 2009-04-22 13:02:12 EDT
globus-rsl-5.0-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/globus-rsl-5.0-2.fc10
Comment 12 Fedora Update System 2009-04-22 13:02:17 EDT
globus-rsl-5.0-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/globus-rsl-5.0-2.fc9
Comment 13 Fedora Update System 2009-04-22 13:02:22 EDT
globus-rsl-5.0-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/globus-rsl-5.0-2.fc11
Comment 14 Fedora Update System 2009-04-27 17:29:02 EDT
globus-rsl-5.0-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2009-04-27 17:36:28 EDT
globus-rsl-5.0-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2009-05-12 00:05:08 EDT
globus-rsl-5.0-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.