Bug 478967 - [RFE] include assert's command output in journal
[RFE] include assert's command output in journal
Status: CLOSED DUPLICATE of bug 840618
Product: Fedora
Classification: Fedora
Component: beakerlib (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Petr Muller
Fedora Extras Quality Assurance
:
Depends On: bl-journal-overhaul
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-06 05:05 EST by Ales Zelinka
Modified: 2016-09-19 22:05 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 07:50:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Zelinka 2009-01-06 05:05:15 EST
I see journal as the primary source of information on a test run, that should contain all necessary information (see also 473911). All other reports should be derived/generated from it. And because assert command output is an important information, it should be included (see discussion of bug 477138).

As of now assert part of journal looks like this:

<log>
 <phase name="fazicka" result="FAIL" score="1" type="FAIL">
  <test message="Running 'echo abc' (Expected 2-7-3-5, got 0)">FAIL</test>
 </phase>
</log>

after output inclusion:

<log>
 <phase name="fazicka" result="FAIL" score="1" type="FAIL">
  <test message="Running 'echo abc' (Expected 2-7-3-5, got 0) result="FAIL">
abc
  </test>
 </phase>
</log>
Comment 1 Petr Muller 2009-01-12 10:17:09 EST
Huh, is this really a good idea? Some outputs can be pretty huge and I would like to keep the journal human readable... But you are definitely right, this should be stored somewhere... 
I'm thinking about an alternate solution, by creating something like a "output log" supplement to the journal, where we would put the rlRun command's output, and the journal would contain a link of some sort to this supplemental log. It's just a quick thought from the top of my head - and it's a bit "cosmetic" compared to your original proposal...
Comment 2 Jan Hutař 2009-01-13 04:11:25 EST
Actually this can be nicely hidden in the journal generated by rlJournalPrintText, but `DEBUG=true rlJournalPrintText` can be another story :)

IMHO journal (XML one) should contain all info generated by the test.
Comment 3 Petr Šplíchal 2009-01-20 04:07:54 EST
Seems to me a good idea to include all test related output in the journal. Perhaps we should just set up some reasonable limit X to prevent the journal to grow too much (maybe include head -X and tail -X or grep -i FAIL when logs are really very long, e.g. for compiling). If we need all the output there's always the TESTOUT.log available.
Comment 5 Petr Muller 2013-01-08 07:50:14 EST

*** This bug has been marked as a duplicate of bug 840618 ***

Note You need to log in before you can comment on or make changes to this bug.