Bug 479005 - add a isomd5sum-python subpackage
add a isomd5sum-python subpackage
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: isomd5sum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FedoraServerTracker
  Show dependency treegraph
 
Reported: 2009-01-06 08:23 EST by Daniel Mach
Modified: 2009-01-08 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-08 17:07:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Mach 2009-01-06 08:23:56 EST
mkinitrd (/usr/libexec/mkliveinitrd) uses only isomd5sum binary.
isomd5sum package depends on python which is not needed in this case.
There's no point to pull python package to minimal installs (consider special installations like lightweight virtual guests).

I propose to move
/usr/lib/python2.6/site-packages/pyisomd5sum.so
to the -python subpacakge and modify dependencies according to that.
Comment 1 Jeremy Katz 2009-01-08 17:07:17 EST
Done for rawhide (well, removed the python module altogether since nothing is using it)

Note You need to log in before you can comment on or make changes to this bug.