Bug 479011 - Remote Configuration tool hangs
Remote Configuration tool hangs
Status: CLOSED WONTFIX
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: grid (Show other bugs)
1.0
All Linux
medium Severity medium
: 1.3
: ---
Assigned To: grid-maint-list
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-06 09:31 EST by Robert Rati
Modified: 2010-10-23 02:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-28 16:04:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Rati 2009-01-06 09:31:18 EST
Description of problem:
The remote configuration tool is hanging when configuring a node.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Robert Rati 2009-01-06 09:32:24 EST
The underlying issue seems to be that puppetrun will hang and wait for what seems like forever if it is able to resolve a node (ie get an IP), but that node isn't responding (doesn't exists, hung, etc).  There doesn't appear to be a timeout value for puppetrun either.
Comment 2 Robert Rati 2009-01-06 09:37:50 EST
After a bit more testing, it seems the issue is related to a node being hung and puppetrun for some reason thinking it needs to wait for a response.  More investigation is needed.

Note You need to log in before you can comment on or make changes to this bug.