Bug 479093 - 4k stacks cause freezing and kernel panics with some wireless cards under ndiswrapper
4k stacks cause freezing and kernel panics with some wireless cards under ndi...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-06 23:34 EST by Lendon Adams
Modified: 2009-01-07 14:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-07 14:00:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lendon Adams 2009-01-06 23:34:24 EST
Description of problem:
The 4k stacks in the Fedora kernel cause freezing and kernel panics with my RTL8185 under ndiswrapper when doing modprobe ndiswrapper. The user has to pull a hard reset due to a complete lock-up, the fix was to compile a custom kernel without 4k stacks.

Version-Release number of selected component (if applicable):
This happens with Fedora 9 & 10 I am using 2.6.27.9-159

How reproducible:
Very

Steps to Reproduce:
1. Install Fedora
2. Install Ndiswrapper and RTL8185 driver.
3. Enter modprobe ndiswrapper

Expected results:
8k stacks by default.
Comment 1 John W. Linville 2009-01-07 14:00:27 EST
ndiswrapper is unsupported and will continue to be unsupported.  We certainly aren't going to use bigger stacks just to make ndiswrapper work.

Did you try the rtl8180 driver that is in the stock kernels?

Note You need to log in before you can comment on or make changes to this bug.