Bug 479097 - No torrent shown in menu
No torrent shown in menu
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: deluge (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Gordon
Fedora Extras Quality Assurance
http://dev.deluge-torrent.org/ticket/704
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-07 00:46 EST by Mamoru TASAKA
Modified: 2009-01-07 18:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-07 18:13:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshort of deluge 1.1.0 rc3 (175.33 KB, image/png)
2009-01-07 00:46 EST, Mamoru TASAKA
no flags Details
debug message for 1.1.0 rc3 (14.72 KB, text/plain)
2009-01-07 00:47 EST, Mamoru TASAKA
no flags Details
screenshort of deluge 1.1.0 rc2 (129.62 KB, image/png)
2009-01-07 00:47 EST, Mamoru TASAKA
no flags Details
workaround for this issue (1.01 KB, patch)
2009-01-07 01:46 EST, Mamoru TASAKA
no flags Details | Diff
Patch from upstream (446 bytes, patch)
2009-01-07 08:45 EST, Mamoru TASAKA
no flags Details | Diff

  None (edit)
Description Mamoru TASAKA 2009-01-07 00:46:25 EST
Created attachment 328346 [details]
screenshort of deluge 1.1.0 rc3

Description of problem:
With 1.1.0 rc3 no torrents are shown in the menu
window.

Version-Release number of selected component (if applicable):
deluge-1.1.0-0.2.rc3.fc11.noarch

How reproducible:
100%

Steps to Reproduce:
1. launch deluge
2.
3.
  
Actual results:
see the attached screenshot

Expected results:
see the attached screenshot of RC2

Additional info:
Comment 1 Mamoru TASAKA 2009-01-07 00:47:10 EST
Created attachment 328347 [details]
debug message for 1.1.0 rc3
Comment 2 Mamoru TASAKA 2009-01-07 00:47:32 EST
Created attachment 328348 [details]
screenshort of deluge 1.1.0 rc2
Comment 3 Mamoru TASAKA 2009-01-07 01:46:11 EST
Created attachment 328350 [details]
workaround for this issue

The attached patch seems to work for me.
Comment 4 Mamoru TASAKA 2009-01-07 08:45:48 EST
Created attachment 328371 [details]
Patch from upstream

I just checked the upstream svn and actually
this was fixed in rev 4492. Would you apply the patch
attached ?
Comment 5 Peter Gordon 2009-01-07 17:50:51 EST
Yeah, I'm experiencing the same error here, though with a slightly different outcome (the torrent is still displayed but simply stays in a state of "Error").

The upstream patch you mention seems to fix this issue as well. I'll commit it momentarily and build a rawhide update.

Thanks for the bug report!
Comment 6 Peter Gordon 2009-01-07 18:13:58 EST
Committed the upstream patch as mentioned, and built to rawhide (deluge-1.1.0-0.3.rc3.fc11). Please don't hesitate to reopen this bug with further details if this issue perists. :)

Note You need to log in before you can comment on or make changes to this bug.