Bug 479107 - toons of undelivered messages on my notebook
toons of undelivered messages on my notebook
Status: CLOSED DUPLICATE of bug 451575
Product: Fedora
Classification: Fedora
Component: sendmail (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-07 04:15 EST by Alexey Kuznetsov
Modified: 2009-01-07 05:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-07 05:48:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
10-sendmail (357 bytes, text/plain)
2009-01-07 04:18 EST, Alexey Kuznetsov
no flags Details

  None (edit)
Description Alexey Kuznetsov 2009-01-07 04:15:45 EST
I configured my notebook to send all everyday reports to my external e-mail address. All configures done by:
- adding /etc/alias root->myusername
- adding /home/myusername/.forward -> address@mail.com

after one weak / one month i got tons of undelivered email. that happens because sendmail try to send mails in wrong time, when i offline, and never do it when i online. Probably sendmail initiate connection on boot when i do not have any interfaces enabled, which ask sendmail to wait for one month before another delivery.


  ----- Transcript of session follows -----
451 gmail.com: Name server timeout
451 /home/axet/.forward: line 1: gmail.com: Name server timeout
Message could not be delivered for 5 days
Message will be deleted from queue
451 /home/axet/.forward: line 1: gmail.com: Name server timeout

Final-Recipient: RFC822; postmaster@localhost.localdomain
X-Actual-Recipient: RFC822; kuznetsov.alexey@gmail.com
Action: failed
Status: 4.4.7
Last-Attempt-Date: Tue, 6 Jan 2009 08:30:05 +0300



One of solution: add /etc/NetworkManager/dispatcher.d/10-sendmail and run service restart on network enable.
Comment 1 Alexey Kuznetsov 2009-01-07 04:18:59 EST
Created attachment 328355 [details]
10-sendmail
Comment 2 Miroslav Lichvar 2009-01-07 04:41:56 EST
Can you please try sendmail-8.14.3-3.fc10 from updates-testing?
Comment 3 Alexey Kuznetsov 2009-01-07 04:50:20 EST
should i remove dispatcher?
Comment 4 Alexey Kuznetsov 2009-01-07 04:53:21 EST
oh, i see now, it should works!
Comment 5 Miroslav Lichvar 2009-01-07 05:48:40 EST

*** This bug has been marked as a duplicate of bug 451575 ***

Note You need to log in before you can comment on or make changes to this bug.