Bug 479119 - seamonkey crashes opening simple web page
seamonkey crashes opening simple web page
Status: CLOSED DUPLICATE of bug 468415
Product: Fedora
Classification: Fedora
Component: seamonkey (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-07 07:10 EST by Deian
Modified: 2009-01-07 07:19 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-07 07:19:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deian 2009-01-07 07:10:55 EST
Description of problem:

Seamonkey alway crashes with segmentation fault when tries to access very simple web page generated from this perl script:

=============CUT HERE===========================
#!/usr/bin/perl -w


use Net::SMTP;
use MIME::Base64;

my $from = 'sender@domain.com';
my $to = 'recipient@domain.com';

printf("Content-type: text/plain\n\n");
printf("\n\nSend email to: $to from: $from");

=============CUT HERE=====================================

I tried with completely clean profile. The same problem. It always crashes.

Version-Release number of selected component (if applicable):

I am running Fedora 10 on thinkpad R61, updated to latest patch level:

kernel: 2.6.27.9-159.fc10.i686
seamonkey: seamonkey-1.1.14-1.fc10.i386

How reproducible:

Steps to Reproduce:
1. Create perl script like the one above
2. Access it with seamonkey
3.
  
Actual results:

Seamonkey crashes with segmentations fault 

Expected results:

Open it with no problems

Additional info:

If I try with seamonkey from mozilla.org I dont have this problem.
Comment 1 Martin Stransky 2009-01-07 07:19:16 EST
It's caused by gcc Bug 468415, as a workaround run seamonkey-1.1.14-2.fc10.i386
(from fedora updates) w/o -O2 optimalization...

*** This bug has been marked as a duplicate of bug 468415 ***

Note You need to log in before you can comment on or make changes to this bug.