Bug 479162 - flash no audio
flash no audio
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
: Desktop
Depends On:
  Show dependency treegraph
Reported: 2009-01-07 12:27 EST by Brandon
Modified: 2009-02-24 22:41 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-02-24 22:41:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
vid of problem (9.91 MB, video/ogg)
2009-01-09 11:44 EST, Brandon
no flags Details

  None (edit)
Description Brandon 2009-01-07 12:27:18 EST
Description of problem:

While going to log on youtube to view a video I get this error message

ALSA lib pcm_dmix.c:1008:(snd_pcm_dmix_open) unable to open slave

Version-Release number of selected component (if applicable):

Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/2008121622 Fedora/3.0.5-1.fc10 Firefox/3.0.5.... Flash 10 most current version

How reproducible:
Occurs on and off

Steps to Reproduce:
1. started firefox through terminal
2. went to watch a video
3. error message pops up with no audio
Actual results:

Expected results:

Additional info:

Fedora 10. Kernel 2.6.27-134
Creative Audigy sound card (pci)
both KDE and Gnome are installed

if i restart a few times sometimes I get sound back in flash. *ran the program in terminal only to get the error message
Comment 1 Brandon 2009-01-09 11:44:56 EST
Created attachment 328564 [details]
vid of problem
Comment 2 Brandon 2009-01-21 08:47:36 EST
Jan 21, 2009

when I installed the totem plug in for you tube I would be watching youtube videos that way because of the broken sound. Well when I was doing that I might start off with 5.1 sound but the audio would go to 2.1 sound. I raised the audio levels in alsa again. and when I was surfing the internet I accidentally click a you tube video and I had gotten audio back. So I tried 3 times in a row making sure audio in flash was not working and when I tried the same thing over sound came back to flash. So the totem bug may point some light out on the sound bug in flash. I have not Idea what is going on but this is interesting.
Comment 3 Lennart Poettering 2009-02-24 22:41:06 EST
Make sure that alsa-plugins-pulseaudio is installed. The error you have shown above suggests that you either have not installed this package or manually reconfigured alsa.

Note You need to log in before you can comment on or make changes to this bug.