Bug 479209 - Cannot create persistence larger than 2GB for ext3 formatted target device
Cannot create persistence larger than 2GB for ext3 formatted target device
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: liveusb-creator (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: kushaldas@gmail.com
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-07 19:19 EST by Jason Farrell
Modified: 2009-09-01 08:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-08 21:28:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Farrell 2009-01-07 19:19:04 EST
Description of problem:
the GUI will not allow you to specify a persistence overlay larger than 2GB (fat32 limit), even when it finds a large enough ext3-formatted target device. Using the livecd-iso-to-disk CLI, huge persistence layers are possible over ext3, and so it should be in the linux-version GUI (obviously no ext3 driver for windows by default though).

Version-Release number of selected component (if applicable):
liveusb-creator-3.0-5.fc10.noarch

Steps to Reproduce:
1. plug in an ext3-formatted usbkey which is 4GB or larger
2. run liveusb-creator and note that the "Persistent Storage" horizontal slider max limit is still 2047MB.

Actual Results:
artificial limit for ext3

Expected Results:
1) a 0-2047MB limit for fat32 target devices
2) a 0-maxdevicesize limit for ext3 target devices
Comment 1 Luke Macken 2009-03-07 19:05:22 EST
From: Xose Vazquez Perez <xose.vazquez@gmail.com>                                                 

new info from a private e-mail from
OGAWA Hirofumi <hirofumi@mail.parknet.co.jp> VFAT/FAT/MSDOS FILESYSTEM
maintainer, he says:

"This was fixed long time ago. However, > 2G can handle only on FAT32
because of fs limitation."

So, there is no reason to put a 2G limit on the overlay file.
Comment 2 Luke Macken 2009-03-08 21:28:07 EDT
This issue should be resolved in version 3.6 of the liveusb-creator.  Please re-open this ticket if you still encounter this problem with the latest version.  Thanks!
Comment 3 Josh Cogliati 2009-09-01 08:44:40 EDT
In version 3.6, it can create an overlay file larger than 2GB on ext[23], but if you boot with the liveusb system, and type df -h, the space is not really there.  Also, I tried dd if=/dev/zero of=a_file, and it ran out of space well before the amount selected on the GUI.  It seems like the limit is the minimum of the size of the iso file or the overlay file.  Since this is ~700 MB, you still can't use all of even a 2GB overlay file.  I think this bug needs to be reopened.

Note You need to log in before you can comment on or make changes to this bug.