Bug 479216 - Most git-* commands have been moved out of $PATH as of git-1.6.1-1.fc11
Most git-* commands have been moved out of $PATH as of git-1.6.1-1.fc11
Status: CLOSED NEXTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
All Linux
low Severity medium
: ---
: ---
Assigned To: Release Notes Tracker
Karsten Wade
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-07 21:49 EST by Todd Zullinger
Modified: 2009-01-26 13:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-08 10:11:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Todd Zullinger 2009-01-07 21:49:35 EST
As announced at http://www.redhat.com/archives/fedora-devel-list/2009-January/msg00071.html, most of the git-* commannds have been moved from the standard $PATH.  Use of the git-* form has been deprecated since around 2006 and upstream moved these commands by default with git-1.6.0.  Users are encouraged to update their scripts.  If changing scripts is not feasible, a workaround is possible:

PATH=$(git --exec-path):$PATH
Comment 1 Jason Taylor 2009-01-08 10:11:03 EST
Added to F11 Bugs/Known Issues page.
Comment 2 Todd Zullinger 2009-01-23 22:21:49 EST
Since it doesn't look like Docs/Beats has been scrubbed up for F11 yet, I added a note to https://fedoraproject.org/wiki/Fedora_11_Alpha_release_notes.  I think we should avoid calling this a bug, as it is quite intentional and in line with upstream's defaults. :)
Comment 3 Karsten Wade 2009-01-26 13:24:07 EST
Thanks Todd, that's the best place to put it right now.  We'll migrate content from there to the main release notes later anyway; it will also appear in the Beta release notes page, etc.

Note You need to log in before you can comment on or make changes to this bug.