Bug 479217 - Full Virtualized Guest does not see "Virtual Disks" presented to it
Full Virtualized Guest does not see "Virtual Disks" presented to it
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-07 21:59 EST by Hector Arteaga
Modified: 2009-12-14 16:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-12 19:07:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hector Arteaga 2009-01-07 21:59:39 EST
Description of problem:
I have a fully-virtualized RH5.3 snapshot6 virtual machine.  When I present a "Virtual Disk" to it the presentation portion goes OK, and virt-manager says that the disk has been presented, but when I power up the VM I do not see the presented "Virtual Disk".  If I present a disk as a scsi device the Guest does not have a problem detecting it.


Version-Release number of selected component (if applicable):
RH5.3 RC1 xen

Steps to Reproduce:
1.  Present a "Virtual Disk" to a fully virtualized RH5.3 guest (I don't know if other exhibit the same behavior.
Comment 1 Chris Lalancette 2009-01-08 02:36:54 EST
Do you have the xen-vbd driver loaded in the guest?  Without that, the guest will never see the virtual disk.

Chris Lalancette
Comment 2 Don Dutile 2009-01-08 12:15:02 EST
Fixed in 2.6.18-128.
Comment 3 Hector Arteaga 2009-01-08 20:29:19 EST
I just tried the same experiment using 2.6.18-128 (RC1) with the same result.  However, I noticed that if the VM is running when you add the "Virtual Disk" it does see the device.  But then it is lost after you reboot the VM.  
I do have the xen-vbd driver loaded (version 2.6.18-125).

[root@localhost ~]# lsmod | grep xen
xen_vbd                49833  0
xen_vnif               58433  0 [permanent]
xen_balloon            45641  1 xen_vnif,[permanent]
xen_platform_pci      118685  3 xen_vbd,xen_vnif,xen_balloon,[permanent]


[root@localhost ~]# modinfo xen_vbd
filename:       /lib/modules/2.6.18-125.el5/kernel/drivers/xenpv_hvm/blkfront/xen-vbd.ko
license:        Dual BSD/GPL
alias:          xen:vbd
srcversion:     2DE57D18B4C08FDBDC27998
depends:        xen-platform-pci
vermagic:       2.6.18-125.el5 SMP mod_unload gcc-4.1
Comment 4 Chris Lalancette 2009-01-09 02:59:59 EST
OK, the fact that it gets lost after you reboot the VM is the correct behavior; things you attach on the fly get lost.  Only things in the configuration file are persistent.  What's the exact command-line you used to attach the disk?

Chris Lalancette
Comment 5 Chris Lalancette 2009-01-09 03:02:17 EST
Oh, also, please get the xend.log and the output from xm list --long from right before and right after you tried to attach the disk.

Thanks,
Chris Lalancette
Comment 6 Don Dutile 2009-01-09 09:47:44 EST
Did you update just the guest kernel?  

I had the same complaint from our perf team yesterday,
made the same recommendation, and the perf team member did
a full update of the guest (not just kernel to -128) to -rc1 &
that resolved the problem for them.

and can you provide a dump of:
Provide a dump of ' grep vbd /lib/modules/2.6.18-128.el5/modules.* '

I want to make sure the dependencies are correct.

- Don

Chris: could he be missing any bug fix to the dom0 tools
       &/or back-end drivers due to the increased num of vbd patch?
Comment 7 Don Dutile 2009-01-12 10:09:51 EST
re: comment #3:

If you upgraded to -128/rc1, then the xen-vbd modinfo should report
version -128, not -125.

Therefore, either you didn't boot & test the -128 kernel, or
the xen-vbd dependencies are seriously messed up.

Please ensure that uname -a reports -128 when you 
do the modinfo xen-vbd check.

*Also*, do a modinfo check on xen-platform-pci;
that *must* show -128; the bug fix is in that module.

Thanks,
Don Dutile
Comment 8 Hector Arteaga 2009-01-12 19:07:25 EST
I tried again with RC2.  This time I loaded the VM from scratch as apposed to the upgrade and I no longer see the issue.  I beleve you were correct in you diagnosis Don.  Thanks for your help.

Closing the bug
-Hector Arteaga

Note You need to log in before you can comment on or make changes to this bug.