Bug 479251 - Internal microphone and mute of speakers when headphone used not working on intel-hda (Realtec-ALC262).
Internal microphone and mute of speakers when headphone used not working on i...
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-01-08 07:33 EST by SmallSandy
Modified: 2009-12-18 02:32 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-12-18 02:32:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 141445 None None None Never

  None (edit)
Description SmallSandy 2009-01-08 07:33:51 EST
Description of problem:
Internal microphone and mute of speakers when headphone used not working on intel-hda (Realtec-ALC262).
Specifically on Sony Vaio NS10J

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Try to use microphone (many different attempts to configure alsa - PulseAudio not installed - but doesn't work with it either)
2. Attach headphone
Actual results:
Microphone doesn't work
Speakers do not mute (sound heard through both speakers and headphone.

Expected results:
Microphone would record (it works under windows - so not a hardware problem)
Speaker woulds mute when headphones attached

Additional info:

Let me know if there is any other information I can give you.
Comment 1 Adam Williamson 2009-02-16 20:57:05 EST
I've tracked this to several upstream reports - see https://bugtrack.alsa-project.org/alsa-bug/view.php?id=4131 , https://bugtrack.alsa-project.org/alsa-bug/view.php?id=4119 for e.g. It appears that 'model=sony-assamd' fixes this. However, I can't tell if upstream ALSA devs yet have enough info on which hardware to apply this model information to so it is handled automatically in future releases.
Comment 2 Richard Stitz 2009-02-18 08:45:39 EST
Sony VAIO VGN-NR160E has same problem....adding the sony-assamd model line resolves the issue as well.  tech specs for this card model can be found at www.stitzweb.com/linux/sonyvaiosoundcard.txt and I have made bugreport to alsa about this particular card as well.
Comment 3 José Tomás Atria 2009-08-03 01:06:03 EDT
Hello, i just wanted to let you guys know that this bug has been discused and apparently solved upstream, as Adam Williamson pointed out.

In the meantime, for those for whom the option model=sony-assamd fixes the headphone jack sense but not the mic, as it was my case, the option model=toshiba-s06 seems to be more correct, as explained by diraimondo in the linked ALSA bug report.
Comment 4 Alessio 2009-10-07 15:01:06 EDT
idem with vgn-aw21m the sound is captable only if I toctoc on the laptop or if i put an external usb mic(excuse my english please
:-( I've tryed with every patch
Comment 5 Jacob Church 2009-11-14 12:24:18 EST
Is there a list of models somewhere? I am having the same issue with a HP G60 I picked up. I tried model=hp , laptop, and a few others but nothing has worked.
Comment 6 Adam Williamson 2009-11-16 21:11:56 EST

Fedora Bugzappers volunteer triage team
Comment 7 Adam Williamson 2009-11-16 21:12:09 EST
(adjust for your kernel version, naturally)

Fedora Bugzappers volunteer triage team
Comment 8 Bug Zapper 2009-11-18 05:41:51 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 9 Bug Zapper 2009-12-18 02:32:33 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.