Bug 479255 - Update for fedora-livedvd-games.ks
Update for fedora-livedvd-games.ks
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-08 08:17 EST by Bruno Wolff III
Modified: 2009-01-10 16:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-10 16:30:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to fedora-livedvd-games.ks (1.58 KB, patch)
2009-01-08 08:20 EST, Bruno Wolff III
no flags Details | Diff

  None (edit)
Description Bruno Wolff III 2009-01-08 08:17:23 EST
Description of problem:
I am working on the games spin for f11. I am attaching a patch for 
fedora-livedvd-games.ks that does several things:
Change getting a desktop to basing off of fedora-livecd-desktop.ks instead of just trying to include gnome as that method is broken (no display manager was pulled in).
Dropping starfighter because it was removed from the repository.
Dropping vdrift because it only works with propietary drivers which won't be on the live dvd.
Dropping uqm stuff since uqm-data got removed from the repository and is too large to be downloading every time the games spin is run.

The resulting squashfs image when using this version of the kickstart file is over 4 GiB. To actually use it, a patch for livecd-creator is needed (RFE in bug 476696). The reulting image will still fit on a DVD. If that patch isn't applied before the alpha release I'll send in another update to the kickstart file with a game temporarily removed to get the size down. Since the current version is broken, I don't think that applying this update is going to make things worse than they already are, if it goes in a little ahead of the livecd-creator change. I do want something working for the alpha release though.

Version-Release number of selected component (if applicable):
spin-kickstarts-0.10.3-3.fc10.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bruno Wolff III 2009-01-08 08:20:38 EST
Created attachment 328462 [details]
Patch to fedora-livedvd-games.ks

Actually attaching the patch would be nice.
Comment 2 Bruno Wolff III 2009-01-08 08:26:00 EST
One other comment is that the patch also changes the size of the build partition. 8000 was too small. The recommended DVD size would be too close even if it did work right now. 10240 provides a bit of headroom.
Comment 3 Bruno Wolff III 2009-01-10 16:30:06 EST
This change has been committed to the git repository.

Note You need to log in before you can comment on or make changes to this bug.