Bug 479265 - country flags should not be used in Deluge
country flags should not be used in Deluge
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: deluge (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Peter Gordon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-08 09:21 EST by Roozbeh Pournader
Modified: 2009-05-31 16:37 EDT (History)
4 users (show)

See Also:
Fixed In Version: deluge-1.1.8-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-10 17:11:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roozbeh Pournader 2009-01-08 09:21:53 EST
Deluge shows flags of countries in the "Peers" tab as an indication of the country where the peer is located. To see the flags, start downloading a file, then click on the file status indicator, and finally click on the "Peers" tab at the bottom of the window.

But in Fedora, we have a policy of not using country flags to refer to countries. See:
http://fedoraproject.org/wiki/Languages#I_wish_to_use_my_country.27s_flag_to_refer_to_my_language...

The flags should either be replaced by ISO 3166-1 alpha-2 or alpha-3 codes (easier) or politically-neutral country names (best source: http://unicode.org/cldr/data/common/main/en.xml).
Comment 1 Peter Gordon 2009-01-08 18:44:23 EST
Well, we're not using the flags to refer to any particular language; only the countries themselves. Are those political worries still appropriate in that case?

Thanks.
Comment 2 Roozbeh Pournader 2009-01-09 11:16:14 EST
Yes. It's flags themselves that are bad. For languages, they are doubly bad (both confusing and controversial), for countries, they're just bad (controversial).
Comment 3 Peter Gordon 2009-01-09 18:09:54 EST
Okay, thanks for the clarification. 

I've spoken with upstream on this via IRC and they have no intention of removing the flags, as this was added on the request of a great many users.

<markybob> codergeek42, point is, a lot of users were asking for flags.  a lot.  we're not gonna go against that for a few crazy ideologists 
<markybob> feel free to quote that in your bug report :P

I'll build updates to fix this momentarily.

Thanks for the bug report!
Comment 4 Kevin Kofler 2009-01-10 12:36:14 EST
IMHO this policy is utterly asinine and should be changed. It also affects at least kdebase (which is already stripping out the flags). Who is the responsible body to get it changed? RH Legal? FPB? FESCo?

I can understand RHEL catering to concerns about making the product sellable in some countries, but why Fedora?

And for me this is a slippery slope. If we ban everything which is forbidden in some country, soon we'll have nothing left to distribute! What's next to go? Cryptography? Games? Web browsers?
Comment 5 Roozbeh Pournader 2009-01-10 14:51:30 EST
I don't think this is just about selling products in countries. Some flags are really political statements, and I don't think Fedora should make such statements. Flags offend people, they even sometimes offend the people that the flag is supposed to represent. For example, the current Iranian flag offends some Iranians!

Still, let's take the general discussion to fedora-legal list. I think that's the best place to either codify it or get rid of it.
Comment 6 Peter Gordon 2009-01-10 17:11:54 EST
Well, even if the policy is a bit silly I can at least understand why it was implemented in the first place. When it comes to this sort of thing, people can be quite picky - and I'd definitely prefer to err on the side of being cautious.

I've removed the flags in Rawhide; but this doesn't seem like something significant enough that would be worth an update on its own for former releases, so I'm closing this bug. (I'll just include it with the next version bump.)

Please feel free to re-open it with further details if it is still an issue.

Thanks again, and regards.
Comment 7 Kevin Kofler 2009-01-10 17:28:34 EST
I think this is a pretty weak rationale for removing upstream features despite users requesting them (even Fedora users, just look at the complaints about flags being ripped out of kdebase, and at least one person complained about this Deluge change as well, it'll only be more once this change hits actual releases), and AFAIK it's also not the real one (but the Taiwan flag being illegal in mainland China is).

Fact it, the vast majority of users do not get offended by flags and expect them to be shown.

Also note that practically all the other distributions ship those flags.
Comment 8 Roozbeh Pournader 2009-01-12 15:53:47 EST
(In reply to comment #7)
> [...]
> Fact it, the vast majority of users do not get offended by flags and expect
> them to be shown.
> [...]

Would you please consider bringing up the issue in fedora-legal-list?

http://www.redhat.com/mailman/listinfo/fedora-legal-list
Comment 9 Kevin Kofler 2009-05-18 14:47:05 EDT
Can you please add a deluge-flags subpackage as per the current flags policy instead of removing them entirely?
Comment 10 Andreas Thienemann 2009-05-19 18:29:00 EDT
(In reply to comment #0)

> But in Fedora, we have a policy of not using country flags to refer to
> countries. See:
> http://fedoraproject.org/wiki/Languages#I_wish_to_use_my_country.27s_flag_to_refer_to_my_language...

You're wrong. That policy is Translation related.
Comment 11 John Thacker 2009-05-19 23:59:27 EDT
Andreas,

No, you're wrong.  See that that policy links to this page:
https://fedoraproject.org/wiki/Package_Maintainers_Flags_Policy

Which specifically gives deluge's use as an example.
Comment 12 Andreas Thienemann 2009-05-20 03:23:12 EDT
(In reply to comment #11)

John,

the Policy page your quoting is a recent change, which is predated by this bug. The page the reporter gave as the reasoning for the bug is not packaging related.
Comment 13 Peter Gordon 2009-05-31 16:37:13 EDT
This is fixed in F-12's rawhide (deluge-1.1.8-1.fc12), with an option "-flags" subpackage as per the referenced policy, with similar fixes for F-11, with similar fixes coming for F-10 and F-11 momentarily. :)

Note You need to log in before you can comment on or make changes to this bug.