Bug 479267 - Bluetooth printing on Fedora 10
Bluetooth printing on Fedora 10
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-08 09:36 EST by Thomas Diesler
Modified: 2009-03-05 11:32 EST (History)
4 users (show)

See Also:
Fixed In Version: 4.30-2.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-05 11:32:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas Diesler 2009-01-08 09:36:09 EST
After an update to fedora 10, I cannot access my bluetooth printer any more.

I used to run hcitool to discover the printer, which still works

Code:
	
> hcitool scan
Scanning ...
    00:0C:F6:06:C0:8A       Sitecom CN-505

In the printer configuration, I used to enter a URL like this

Printer URL
bluetooth://000CF606C08A/

Note, the "bluetooth" protocol is not offered any more in printer setup.

I read that Fedora 10 comes with an updated BlueZ 4 package, which has an improved gnome applet.

Code:

[tdiesler@tdvaio ~]$ sudo yum list installed | grep bluez
bluez.i386                                4.19-1.fc10                  installed
bluez-alsa.i386                           4.19-1.fc10                  installed
bluez-cups.i386                           4.19-1.fc10                  installed
bluez-gnome.i386                          1.8-8.fc10                   installed
bluez-libs.i386                           4.19-1.fc10                  installed

The applet discovers the printer, but fails pairing with the device. There seems to be short flash up of a pincode error message (which I cant read).

I've been using bluetooth printing with no problems since Fedora 6.

Any suggestions on how to configure bluez cups printing on Fedora 10?
Comment 1 Thomas Diesler 2009-01-08 09:39:24 EST
Here is the associated forum thread

http://forums.fedoraforum.org/showthread.php?p=1141904
Comment 2 Andrey 2009-03-03 14:01:25 EST
This bug seems to be caused by the same reason as https://bugzilla.redhat.com/show_bug.cgi?id=472686 but I can be wrong.
Comment 3 Bastien Nocera 2009-03-04 11:12:54 EST
No, the cups bluetoot backend binary was just a libtool stub, but nobody noticed. Already fixed in:
https://admin.fedoraproject.org/updates/F10/FEDORA-2009-1924
and pushed to stable.
Comment 4 Fedora Update System 2009-03-05 11:32:15 EST
bluez-4.30-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.