Bug 47930 - Kickstart can't make fixed partitions
Summary: Kickstart can't make fixed partitions
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: ia64 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-09 06:00 UTC by Shinya Narahara
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-17 16:20:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Now we do it with silly method... (6.31 KB, text/plain)
2001-07-09 06:02 UTC, Shinya Narahara
no flags Details

Description Shinya Narahara 2001-07-09 06:00:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [ja] (WinNT; U)

Description of problem:
We can't make fixed partitions by using kickstart parameter "part".
The option --onprimary and --asprimary doesn't work well.


How reproducible:
Always

Steps to Reproduce:
1.Make kickstart file on floppy.
2.Assign sda1 as /boot/efi, sda2 as swap, and sda3 as /. The descriptions are:
        part /boot/efi --size 256M   --ondisk sda --onprimary 1 --type=6
        part swap       --size 2047M --ondisk sda --onprimary 2
        part /            --size 4096M --ondisk sda --onprimary 3
3. Install redhat Linux by using the file above.


Actual Results:  Actual partitions are:
/boot/efi     /dev/sda1
swap           /dev/sda2
/                /dev/sda5



Expected Results:  Expected partitions are:
/boot/efi     /dev/sda1
swap           /dev/sda2
/                /dev/sda3


Additional info:

In generally, this actual results aren't very bad, because partitions are made
and mounted normally.
But especially for DAC960(/dev/rd/c0d0p#), as you know dac960 doesn't have
enough partitions(max is 7), we really wanna make them as we assign.

Comment 1 Shinya Narahara 2001-07-09 06:02:09 UTC
Created attachment 23047 [details]
Now we do it with silly method...

Comment 2 Brent Fox 2001-07-17 16:19:58 UTC
We have changed the partitioning section of the installer, so this should not be
a problem with future releases.  Thank you for your report.


Note You need to log in before you can comment on or make changes to this bug.