Bug 479319 - Some documentation seems to be missing
Some documentation seems to be missing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ecryptfs-utils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
: FutureFeature
Depends On: 487088
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-08 15:17 EST by Piergiorgio Sartor
Modified: 2011-12-07 06:59 EST (History)
5 users (show)

See Also:
Fixed In Version: ecryptfs-utils-93-2.fc17
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-07 06:59:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piergiorgio Sartor 2009-01-08 15:17:06 EST
Description of problem:
It seems, at least for me, quite difficult to find information on how to setup the PAM mount of the "Private" directory inside the user directory.

First, the documentation about "pam_ecryptfs.so" is confusing, specifying different pam files ("common-auth", "common-session", "system-auth"), with different configurations and not taking into account that some of those files ("system-auth") are automatically generated.
There is no Fedora specific information on how to setup the whole thing, at least I could not find it.

Second, the documentation about ".ecryptfsrc" is missing completely, this seems to be an upstream issue, nevertheless it would be nice to have some information on this topic too.

Thanks.

Version-Release number of selected component (if applicable):
ecryptfs-utils-61-0.fc10
Comment 1 Fedora Admin XMLRPC Client 2009-02-18 02:47:12 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Piergiorgio Sartor 2009-02-19 10:49:49 EST
(In reply to comment #0)

> First, the documentation about "pam_ecryptfs.so" is confusing, specifying
> different pam files ("common-auth", "common-session", "system-auth"), with
> different configurations and not taking into account that some of those files
> ("system-auth") are automatically generated.
> There is no Fedora specific information on how to setup the whole thing, at
> least I could not find it.

Comment #4 of bug #479727 explains the proper /etc/pam.d/system-auth setup.
Nevertheless, some unified documentation is still needed.

pg
Comment 3 Piergiorgio Sartor 2011-08-15 04:52:38 EDT
Hi all,

maybe this one could be closed. It seems in F16 the "authconfig" tool is doing the job properly.

Thanks,

bye,

pg

Note You need to log in before you can comment on or make changes to this bug.