Bug 479321 - cluster pvmove hangs in mixed arch cluster
cluster pvmove hangs in mixed arch cluster
Status: CLOSED DUPLICATE of bug 488102
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2-cluster (Show other bugs)
5.4
All Linux
high Severity high
: rc
: ---
Assigned To: Jonathan Earl Brassow
Cluster QE
:
Depends On:
Blocks: 488102
  Show dependency treegraph
 
Reported: 2009-01-08 15:26 EST by Dean Jansa
Modified: 2010-05-19 09:54 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-19 09:54:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dean Jansa 2009-01-08 15:26:17 EST
Description of problem:

3 node cluster -- one x86_64 node running 32 bit package, one x86_64, and one ia64.  Run a pvmove, which will result in the copy % stalling at random point.  A dmsetup suspend followed by a dmsetup resume will start he copy over, but will end up stuck at some new random point.

The 32 bit node seems fine, but on the 64 bit nodes I see the following:

sdb5: rw=16, want=18303754785540539776, limit=61223652
attempt to access beyond end of device
sdb5: rw=16, want=18303754785540539520, limit=61223652
device-mapper: raid1: Unable to read from primary mirror during recovery
attempt to access beyond end of device
sdb5: rw=16, want=18303754785540538880, limit=61223652
attempt to access beyond end of device

The want=XXX seems suspicious.


Version-Release number of selected component (if applicable):
RHEL5.3-Server-20081218.1-RC
2.6.18-128.el5
lvm2-cluster-2.02.40-7.el5
lvm2-2.02.40-6.el5
kmod-cmirror-0.1.21-10.el5
cmirror-1.1.36-1.el5
Comment 1 Jonathan Earl Brassow 2009-03-02 13:12:12 EST
Clearing the flags on this bug.  bug 488102 is now the aggregate for
architecture mixing bugs and will hold the flags.
Comment 3 Jonathan Earl Brassow 2010-05-19 09:54:40 EDT
should be fixed by way of bug 488102 in rhel5.5.  Moving state to MODIFIED.

*** This bug has been marked as a duplicate of bug 488102 ***

Note You need to log in before you can comment on or make changes to this bug.