Bug 479325 - libmilter.a missing -fPIC for x86_64
libmilter.a missing -fPIC for x86_64
Status: CLOSED DUPLICATE of bug 309281
Product: Fedora
Classification: Fedora
Component: sendmail (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks: pymilter
  Show dependency treegraph
 
Reported: 2009-01-08 16:03 EST by Stuart D Gathman
Modified: 2009-01-20 13:54 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 13:54:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stuart D Gathman 2009-01-08 16:03:46 EST
Description of problem:
libmilter.a missing -fPIC compile flag for x86_64 (i386 has it)

Version-Release number of selected component (if applicable):
sendmail-devel-8.14.3-3.fc11.x86_64

How reproducible:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1040514
  
Actual results:
http://koji.fedoraproject.org/koji/getfile?taskID=1040514&name=build.log

Expected results:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1040492

Additional info:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1040488
Comment 1 Stuart D Gathman 2009-01-09 23:48:05 EST
Why does a static library need -fPIC ? Because it is commonly linked with dynamically loaded modules.  There is a project to provide a dynamic libmilter.so - but in the meantime, libmilter.a need to be statically linkable with dynamic modules.
Comment 2 Miroslav Lichvar 2009-01-20 13:54:52 EST
sendmail-8.14.3-4.fc11 now has shared libmilter. The pymilter package seems to build fine, it just needs to remove -lsmutil from the linking command.

*** This bug has been marked as a duplicate of bug 309281 ***

Note You need to log in before you can comment on or make changes to this bug.