Bug 479341 - javahelp2 executables (jh2indexer and jh2search) will not run
Summary: javahelp2 executables (jh2indexer and jh2search) will not run
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: javahelp2
Version: 10
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Victor G. Vasilyev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-01-08 23:07 UTC by Chris Burghart
Modified: 2009-05-15 19:51 UTC (History)
4 users (show)

Fixed In Version: 2.0.05-6.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-05-14 02:53:03 UTC
Type: ---


Attachments (Terms of Use)

Description Chris Burghart 2009-01-08 23:07:14 UTC
Description of problem: 
The executable scripts delivered with javahelp2 (/usr/bin/jh2indexer and /usr/bin/jh2search) will not run because they refer to nonexistent jar file javahelp.jar.  The scripts should use javahelp2.jar, which is delivered in the package.

Version-Release number of selected component (if applicable): 2.0.05


How reproducible: very


Steps to Reproduce:
1. execute /usr/bin/jh2indexer with no arguments
  
Actual results:
$ jh2indexer
/usr/bin/build-classpath: error: Could not find javahelp Java extension for this JVM
/usr/bin/build-classpath: error: Some specified jars were not found


Expected results:
$ jh2indexer
No files specified to index
 Usage:   java JavaHelp.Index options file ...
 Options: -c file   config file
          -db file  generated database file name
          -verbose  verbose documentation
          -nostopwords ignore stop words
          -locale language_country_variant
          -logfile log file name
Note: config file composition:
          IndexRemove /public_html/JavaHelp/demo
          IndexPrepend ..
          StopWords word1 ... wordN
          StopWordsFile stopWordFileName
          File /public_html/JavaHelp/demo/first.html
          File=/public_html/JavaHelp/demo/second.html
          ...


Additional info:  
The problem is easily remedied by changing the line:

    BASE_JARS=javahelp

to

    BASE_JARS=javahelp2

in the /usr/bin/jh2indexer and /usr/bin/jh2search scripts.

Comment 1 Milos Jakubicek 2009-04-27 10:44:45 UTC
Confirming & going to fix this soon -- Jaroslav, are you still around?

Comment 2 Milos Jakubicek 2009-04-27 12:19:45 UTC
Fixed in F11 and devel branches.

Comment 3 Fedora Update System 2009-04-27 12:49:13 UTC
javahelp2-2.0.05-6.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/javahelp2-2.0.05-6.fc10

Comment 4 Fedora Update System 2009-04-27 21:36:39 UTC
javahelp2-2.0.05-6.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update javahelp2'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-4025

Comment 5 Fedora Admin XMLRPC Client 2009-04-30 07:37:02 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 6 Fedora Update System 2009-05-14 02:52:59 UTC
javahelp2-2.0.05-6.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Chris Burghart 2009-05-15 19:51:58 UTC
The rawhide RPM worked fine, as does the new fc10 stable one.  Thanks!


Note You need to log in before you can comment on or make changes to this bug.