Bug 479343 - RH5.3 x64 RC1 reboots while installing a virtual machine
RH5.3 x64 RC1 reboots while installing a virtual machine
Status: CLOSED DUPLICATE of bug 479754
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.3
x86_64 Linux
high Severity urgent
: rc
: ---
Assigned To: Chris Lalancette
Martin Jenner
:
Depends On:
Blocks: 451642
  Show dependency treegraph
 
Reported: 2009-01-08 18:12 EST by Jim Evans
Modified: 2009-01-16 04:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-16 04:32:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
messages file showing both reboots (367.19 KB, text/plain)
2009-01-08 18:12 EST, Jim Evans
no flags Details
xend.log showing both reboots (36.27 KB, text/plain)
2009-01-08 18:17 EST, Jim Evans
no flags Details
beginning captures the OOPS that causes the system reboot (28.81 KB, text/plain)
2009-01-09 17:50 EST, Jim Evans
no flags Details

  None (edit)
Description Jim Evans 2009-01-08 18:12:41 EST
Created attachment 328506 [details]
messages file showing both reboots

Description of problem:
While installing an RH5.3 x64 RC1 VM the system reboots. Nothing on
the screen with any error messages. Just reboots. 


Version-Release number of selected component (if applicable):
RH5.3 RC1

How reproducible:
2 out of 2 so 100%


Steps to Reproduce:
1. Start installing a para-virt VM with x86_64 RC1
2. Wait some time to insure installation is well under way
3. Set up to install another VM with VMM and watch the system reboot
  
Actual results:
System reboots showing nothing on the screen

Expected results:
System stays up so I can finish the install

Additional info:

HP Blade BL685c
4GB ram
EVA-XL BootFromSan for Dom0. Used multipath during installation 
EVA-XL additional lun split for VM1 and VM2 install - 10GB each as LVs
RC1 bits for x86_64

1st time: VM1-para was installing and at some point during the installation I started getting the second VM ready to install. I got to defining which logical volume to install to and the whole system rebooted. I never got to even start the 2nd VM install. xend.log shows 16:23:56 right before the reboot.

2nd time: VM1-para was installing and I was watching to see if I could spot where in the installation it may fail. I brought up VMM and got to type in the name of VM2 and as VM1 got to loading "xulrunner" the system rebooted. I'm guessing it will happen anywhere but I wanted to give you all the data I had. xend.log shows 16:50.11 right before the reboot.

Obviously a user running program shouldn't be able to reboot a system, hence the "urgent". That plus the release schedule.

Attached are the messages file and the xend.log file. If there is any additional data Red Hat would like from this system the way it is, let me know.
Comment 1 Jim Evans 2009-01-08 18:17:07 EST
Created attachment 328508 [details]
xend.log showing both reboots
Comment 2 Chris Lalancette 2009-01-09 02:48:44 EST
We really need either a core dump or, at the least, a stack trace from the crash to see what is going on here.  Can you setup kdump or attach a serial console and get this information for us?

Thanks,
Chris Lalancette
Comment 3 Jim Evans 2009-01-09 08:33:09 EST
I'll see what I can do for you
Comment 4 Jim Evans 2009-01-09 17:50:27 EST
Created attachment 328600 [details]
beginning captures the OOPS that causes the system reboot

Serial line capture with printk turned on

"Unable to handle kernel paging request at ffff8800bd029f58 RIP"
Comment 5 Jim Evans 2009-01-09 17:55:32 EST
The beginning of the file has the error captured and then I let the system reboot in case you can fathom anything else about the system you need.

I had VM1-para installing and after a bit brought up the VMM gui to get VM2 queued up. VM1 got to "cyrus" and froze so I'm guessing it can fail at any spot. The VM2 install was not started, just brought up the gui and started to get things ready.

Hope this helps....  jim
Comment 6 Jim Evans 2009-01-12 12:28:04 EST
If it helps to debug this issue I'd like to extend an offer for someone from the Westford office to come to Marlborough just down the road and get some hands on time.
Comment 7 Jim Evans 2009-01-13 15:52:00 EST
479754 may be related and that is against RC2.
Comment 8 Chris Lalancette 2009-01-16 04:32:24 EST
OK, yes.  This BZ is the same as 479754, I'm pretty sure, based on the gnttab_transfer line in the serial output.  I'm going to close it as such for the time being; if it turns out not to be the case, we can re-open it.

Chris Lalancette

*** This bug has been marked as a duplicate of bug 479754 ***

Note You need to log in before you can comment on or make changes to this bug.