Bug 479371 - Broken hinting on "u" in Liberation Mono Bold
Broken hinting on "u" in Liberation Mono Bold
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
11
All All
low Severity medium
: ---
: ---
Assigned To: Caius Chance
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks: 485746
  Show dependency treegraph
 
Reported: 2009-01-09 00:34 EST by Cody Boisclair
Modified: 2009-06-30 22:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-30 22:49:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Liberation Mono Bold 1.04.93 with antialiasing on (57.65 KB, image/png)
2009-01-09 00:34 EST, Cody Boisclair
no flags Details
Liberation Mono Bold 1.04.93 with antialiasing off (39.77 KB, image/png)
2009-01-09 00:35 EST, Cody Boisclair
no flags Details
test fix, post auto-hinting applied with fontforge (102.67 KB, application/octet-stream)
2009-01-20 20:49 EST, Caius Chance
no flags Details
Appearance of auto-hinted "u" in Liberation Mono (41.50 KB, image/png)
2009-01-20 21:27 EST, Cody Boisclair
no flags Details
screenshot w/ fix sample (70.91 KB, image/png)
2009-01-20 22:16 EST, Caius Chance
no flags Details
screenshot w/ fix sample (120.80 KB, image/png)
2009-01-20 22:17 EST, Caius Chance
no flags Details
screenshot w/ fix sample (68.75 KB, image/png)
2009-01-20 22:19 EST, Caius Chance
no flags Details
screenshot w/ fix sample (69.89 KB, image/png)
2009-01-20 22:20 EST, Caius Chance
no flags Details
fixed by copying hinting from "u" in v1.03 (102.64 KB, application/octet-stream)
2009-01-20 22:44 EST, Cody Boisclair
no flags Details
Screenshot of fix from attachment 329538 (42.15 KB, image/png)
2009-01-20 22:46 EST, Cody Boisclair
no flags Details

  None (edit)
Description Cody Boisclair 2009-01-09 00:34:49 EST
Created attachment 328517 [details]
Liberation Mono Bold 1.04.93 with antialiasing on

Description of problem:
Though the hinting has been fixed in Sans Bold as of version 1.04.92, the letter  "u" still has incorrect hinting in Mono Bold, an error that's quite noticeable in certain sizes on any system with bytecode hinting enabled. I'm attaching a screenshot from Ubuntu to demonstrate; of particular note are 9 point (the second line) and 12 point (the 5th line).

Version-Release number of selected component (if applicable):
1.04.93
Comment 1 Cody Boisclair 2009-01-09 00:35:40 EST
Created attachment 328518 [details]
Liberation Mono Bold 1.04.93 with antialiasing off
Comment 2 Caius Chance 2009-01-20 20:47:56 EST
(In reply to comment #1)

Would you mean the pixel on bottom left corner?
Comment 3 Caius Chance 2009-01-20 20:49:42 EST
Created attachment 329524 [details]
test fix, post auto-hinting applied with fontforge

Could you please check if this .ttf has 'u' fixed?
Comment 4 Cody Boisclair 2009-01-20 21:27:07 EST
Created attachment 329526 [details]
Appearance of auto-hinted "u" in Liberation Mono
Comment 5 Cody Boisclair 2009-01-20 21:27:37 EST
Still broken, but in a different way. See attachment 329526 [details].

For what it's worth, the "u" is OK in version 1.03 of the font - can the hinting be copied from that version?
Comment 6 Caius Chance 2009-01-20 21:50:20 EST
I have checked again. The hinting instructions and cvt are totally same between ver 1.03 and current version.
Comment 7 Cody Boisclair 2009-01-20 22:00:23 EST
Weird. No idea what would be causing that. I may have to play with it in FontForge some myself to see what might be causing this quirk...
Comment 8 Caius Chance 2009-01-20 22:15:04 EST
I have triaged on my Fedora 10 and Liberation Mono Bold looks fine (attached screenshots).

Since I didn't have problem on my OpenOffice, I currently have no idea about this yet.
Comment 9 Caius Chance 2009-01-20 22:16:35 EST
Created attachment 329532 [details]
screenshot w/ fix sample
Comment 10 Caius Chance 2009-01-20 22:17:14 EST
Created attachment 329535 [details]
screenshot w/ fix sample
Comment 11 Caius Chance 2009-01-20 22:19:12 EST
Created attachment 329536 [details]
screenshot w/ fix sample
Comment 12 Caius Chance 2009-01-20 22:20:14 EST
Created attachment 329537 [details]
screenshot w/ fix sample
Comment 13 Cody Boisclair 2009-01-20 22:22:53 EST
It looks fine with hinting turned off on my system too; same if I set fontconfig to use auto-hinting. Only if I use bytecode hinting (which is enabled by default in Ubuntu) does it look "wrong".
Comment 14 Cody Boisclair 2009-01-20 22:44:50 EST
Created attachment 329538 [details]
fixed by copying hinting from "u" in v1.03
Comment 15 Cody Boisclair 2009-01-20 22:46:27 EST
Created attachment 329539 [details]
Screenshot of fix from attachment 329538 [details]
Comment 16 Cody Boisclair 2009-01-20 22:48:04 EST
I fixed it by using Edit -> Copy From -> TrueType Instructions to copy the "u" character from version 1.03 to 1.04. The font file itself is in attachment 329538 [details], and a screenshot of how the fixed version appears under bytecode hinting is in attachment 329539 [details]. Feel free to adopt this patched version.
Comment 17 Bug Zapper 2009-06-09 06:37:56 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 18 Caius Chance 2009-06-30 22:49:41 EDT
Zap this bug. Please reopen if bug persists after testing on latest version.

Note You need to log in before you can comment on or make changes to this bug.