Bug 479374 - statd fails to create SM_DIR
statd fails to create SM_DIR
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nfs-utils (Show other bugs)
5.2
All Linux
low Severity medium
: rc
: ---
Assigned To: Steve Dickson
Martin Jenner
https://bug.oraclecorp.com/pls/bug/we...
: Regression, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-09 00:55 EST by Wengang Wang
Modified: 2011-10-13 02:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-17 14:31:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch which fixes the bug (466 bytes, patch)
2009-01-09 00:55 EST, Wengang Wang
no flags Details | Diff

  None (edit)
Description Wengang Wang 2009-01-09 00:55:02 EST
Created attachment 328520 [details]
patch which fixes the bug

service nfslock start may fail when /var/lib/nfs/statd/sm doesn't exist.
that's because of opendir() against /var/lib/nfs/statd/sm fails. root reason is the directory is not created if it doesn't exist.
this problem exist in both RHEL5 and RHEL4

according code in shuffle_dirs(), since st is not initailized, whether
the SM_DIR is created depends on the thread stack of rpc.statd.
the fix is to insert a memset() before calling stat().

attached patch(based on nfs-utils 1.0.9) fixes this problem.
please include this patch for next release.
Comment 2 Karel Volný 2009-03-20 07:03:51 EDT
Can anyone please add info how this bug can be reproduced? - I was unable to do so, in all my tries the directory got re-created on nfslock startup ...
Comment 4 RHEL Product and Program Management 2009-04-29 16:25:27 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.
Comment 5 Wengang Wang 2009-05-18 22:25:17 EDT
please include it in the next release.
the same fix for EL4 is already included, see https://bugzilla.redhat.com/show_bug.cgi?id=479376

Note You need to log in before you can comment on or make changes to this bug.