Bug 479380 - breakpoints don't work
breakpoints don't work
Status: CLOSED DUPLICATE of bug 475645
Product: Fedora
Classification: Fedora
Component: gdb (Show other bugs)
rawhide
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: Jan Kratochvil
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-09 02:57 EST by Jim Meyering
Modified: 2013-03-13 16:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 03:20:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Meyering 2009-01-09 02:57:49 EST
Description of problem: breakpoints are ignored

Version-Release number of selected component (if applicable):
  gdb-6.8.50.20081214-1.fc11.x86_64
  gcc-4.3.2-7.x86_64

How reproducible: always

Steps to Reproduce:

  $ printf '#include <stdio.h>\nint main(){printf("foo");return 0;}\n' > k.c
  $ gcc -g k.c
  $ gdb -q a.out
  (gdb) b main
  Breakpoint 1 at 0x4004b0: file k.c, line 2.
  (gdb) r
  Starting program: /t/a.out 
  foo
  Program exited normally.
  (gdb) 
 
Actual results: as above

Expected results: execution stops at entry to "main"

Additional info:
Comment 1 Jan Kratochvil 2009-01-09 03:20:43 EST

*** This bug has been marked as a duplicate of bug 475645 ***

Note You need to log in before you can comment on or make changes to this bug.