Bug 479382 - qpid-config syntax error
qpid-config syntax error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: python-qpid (Show other bugs)
beta
All Linux
high Severity high
: 1.1
: ---
Assigned To: Ted Ross
Jan Sarenik
http://coding.derkeiler.com/Archive/P...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-09 03:26 EST by Jan Sarenik
Modified: 2009-03-20 04:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-20 04:09:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example of working qpid-config (13.97 KB, application/octet-stream)
2009-01-09 04:50 EST, Jan Sarenik
no flags Details

  None (edit)
Description Jan Sarenik 2009-01-09 03:26:03 EST
qpid-config command which residies in python-qpid package
is not working on RHEL because the updated syntax of the
'try:' at the end of command is not valid in older versions
of Python (pre 2.5), see

http://coding.derkeiler.com/Archive/Python/comp.lang.python/2007-06/msg03531.html

Tested on RHEL-5.2-i386, python-qpid-0.4.732797-1.el5
Comment 1 Jan Sarenik 2009-01-09 04:33:55 EST
# qpid-config
  File "/usr/bin/qpid-config", line 390
    finally:
          ^
SyntaxError: invalid syntax
Comment 2 Jan Sarenik 2009-01-09 04:50:22 EST
Created attachment 328531 [details]
Example of working qpid-config

Just the latest top-level 'try: ' call is important.
Comment 3 Ted Ross 2009-01-09 09:34:10 EST
This regression was introduced upstream in rev 727462.  It has been fixed in 733041 (trunk) and 733043 (M4 branch).
Comment 4 Frantisek Reznicek 2009-01-12 05:51:30 EST
The issue has been fixed. Validated on RHEL 5.2 i386 / x86_64 on package
python-qpid-0.4.733051-1.el5.

->VERIFIED

Note You need to log in before you can comment on or make changes to this bug.