Bug 479385 - Updated to 3.5.21
Updated to 3.5.21
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: djvulibre (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Rakesh Pandit
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 469811
  Show dependency treegraph
 
Reported: 2009-01-09 03:49 EST by Rakesh Pandit
Modified: 2009-03-07 02:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-07 02:57:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rakesh Pandit 2009-01-09 03:49:23 EST
Description of problem:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=458211 <--- bug gas been fixed in 3.5.20-3

Additional info:

I require this bug to be fixed for building pdf2djvu 0.5.0.
Comment 1 Rakesh Pandit 2009-01-09 05:05:07 EST
3.5.21 is already out.
Comment 2 Rakesh Pandit 2009-01-09 05:07:53 EST
NEW IN VERSION 3.5.21
---------------------
- Speed improvement on multicore platforms
- Ddjvu now can produce pdf output.
Comment 3 Matthias Saou 2009-01-09 05:44:22 EST
I've approved your pkgdb requests, so feel free to take care of this. Note that there are a few djvulibre bug reports I haven't yet taken care of too : bugs #436938 #443953 #444699. Feel free to have a look and fix ;-)
Comment 4 Rakesh Pandit 2009-01-16 22:38:02 EST
Will update in a while.
Comment 5 Fedora Update System 2009-01-16 23:26:22 EST
djvulibre-3.5.21-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/djvulibre-3.5.21-1.fc9
Comment 6 Fedora Update System 2009-01-16 23:26:37 EST
djvulibre-3.5.21-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/djvulibre-3.5.21-1.fc10
Comment 7 Rakesh Pandit 2009-01-17 00:54:44 EST
Oh I missed that. It updates the soname to so.15->so.21

and 

$ repoquery --whatrequires libdjvulibre.so.15
kdegraphics-libs-7:4.1.96-1.fc11.i386
evince-djvu-0:2.25.4-1.fc11.i386
djview4-0:4.3-2.fc10.i386
ImageMagick-djvu-0:6.4.5.5-5.fc11.i386
Comment 8 Rakesh Pandit 2009-01-17 01:57:29 EST
I have pushed back the request for testing on stable for now. On rawhide I pushed and sent a request to maintainers for a rebuild.
Comment 9 Rakesh Pandit 2009-03-07 02:57:06 EST
Stable branch push requires communication with other pkg deps but they have been non-responsive. So, I have fixed this bug in rawhide and updated other packages to sync with new soname.

pdf2djvu for which I needed this fix is now available in rawhide.

This bug is also fixed in rawhide. Will close.

Thanks Matthias!

Note You need to log in before you can comment on or make changes to this bug.