Bug 479397 - internal system error, package manager error add/remove software
internal system error, package manager error add/remove software
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-09 04:51 EST by Retlaw Dlawso
Modified: 2009-01-19 06:45 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-19 06:45:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Retlaw Dlawso 2009-01-09 04:51:58 EST
Description of problem: package manager error


Version-Release number of selected component (if applicable):


How reproducible: control center   add/remove software   search parameter   find
a report opens: an internal system error has occured ...


Steps to Reproduce:
1.add/remove software
2.search +parameter 
3.find
  
Actual results:
report: an internal system error has occures...

Expected results:
software package

Additional info:
Comment 1 Richard Hughes 2009-01-14 08:23:33 EST
What does the internal error say? What version PackageKit are you using?
Comment 2 Retlaw Dlawso 2009-01-16 12:24:14 EST
download jan5 2009 (unexperienced user)
FEDORA-10-x86_64-DVD.ISO  Kernel 2.6.27.9-159.fc10.x86-64 including
rpm 4.6.0.-0.rc1.7.x86_64.rpm
before installation of "yum-utils-1.1.18-2.fc.10.noarch.rpm" everything seemed to work o.k., since then the package manager responds with the report "An internal system error has occured", the report contains "more details":
Error Type: <type 'exceptions.TypeError'>
Error Value: 'NoneType' object is unsubscriptable
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2280, in <module>
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2277, in main
    backend.dispatcher(sys.argv[1:])
  File : /usr/lib/python2.5/site-packages/packagekit/backend.py, line 600, in dispatcher
    self.dispatch_command(args[0], args[1:])
  File : /usr/lib/python2.5/site-packages/packagekit/backend.py, line 504, in dispatch_command
    self.get_distro_upgrades()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1657, in get_distro_upgrades
    self._check_init()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1965, in _check_init
    self.yumbase.repos.doSetup()
  File : /usr/lib/python2.5/site-packages/yum/repos.py, line 71, in doSetup
    self.ayum.plugins.run('postreposetup')
  File : /usr/lib/python2.5/site-packages/yum/plugins.py, line 178, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File : /usr/lib/yum-plugins/rpm-warm-cache.py, line 32, in postreposetup_hook
    cmd = commands[0]
since then, no system nor software update is possible, however, the system is working well
Comment 3 Richard Hughes 2009-01-16 13:09:08 EST
Remove yum-rpm-warm-cache -- it breaks PackageKit.
Comment 4 Retlaw Dlawso 2009-01-16 15:49:22 EST
Best thanks, everything o.k.

Note You need to log in before you can comment on or make changes to this bug.