Bug 479407 - KVM guest locks up after upgrade to F10
KVM guest locks up after upgrade to F10
Status: CLOSED DUPLICATE of bug 475598
Product: Fedora
Classification: Fedora
Component: kvm (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-01-09 07:33 EST by Pierre Ossman
Modified: 2009-01-12 07:47 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-01-12 07:47:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
libvirt log (677 bytes, application/octet-stream)
2009-01-09 12:28 EST, Pierre Ossman
no flags Details

  None (edit)
Description Pierre Ossman 2009-01-09 07:33:35 EST
I upgraded a F8 host with a bunch of F9 guests to F10 (both host and guests). Now I am plagued by guests hanging completely and having to forcefully restart them periodically.

I've turned of console blanking in hopes of seeing a panic, but there is no output when the machine locks up.

Doing a strace on the qemu process gives this:

timer_gettime(0x1, {it_interval={0, 0}, it_value={0, 0}}) = 0
timer_settime(0x1, 0, {it_interval={0, 0}, it_value={0, 33000000}}, NULL) = 0
select(13, [4 8 10 11 12], [], [], {1, 0}) = 1 (in [11], left {0, 967000})
read(11, "\16\0\0\0\0\0\0\0\376\377\377\377\0\0\0\0\0\0\0\0\0\0\0\0\1\0\0\0\0\0\0\0\0"..., 128) = 128
rt_sigaction(SIGALRM, NULL, {0x408380, ~[KILL STOP RTMIN RT_1], SA_RESTORER, 0x38e900f0f0}, 8) = 0
read(11, 0x7fff0b6db450, 128)           = -1 EAGAIN (Resource temporarily unavailable)

I'm afraid I don't know how to debug this further. Logs on host and guest do not have anything around the time it hangs.
Comment 1 Mark McLoughlin 2009-01-09 11:48:34 EST
thanks for the report pierre

Could you attach the log file for the guest from /var/log/libvirt/qemu?

Also the "virsh dumpxml" output for the guest? (assuming you're using libvirt)

If you're using a qcow image, could you try convert it to raw and see if that helps?
Comment 2 Mark McLoughlin 2009-01-09 11:52:54 EST
pierre: also look at bug #479407 and see if any of the suggestions there help
Comment 3 Pierre Ossman 2009-01-09 12:28:03 EST
Created attachment 328568 [details]
libvirt log

This log is from a machine that had locked up at the time the log was copied.

dumpxml output:

<domain type='kvm' id='5'>
    <type arch='i686' machine='pc'>hvm</type>
    <boot dev='hd'/>
  <clock offset='utc'/>
    <disk type='block' device='disk'>
      <source dev='/dev/system/citroen'/>
      <target dev='hda' bus='ide'/>
    <disk type='block' device='disk'>
      <source dev='/dev/system/samba'/>
      <target dev='hdb' bus='ide'/>
    <interface type='ethernet'>
      <mac address='00:16:3e:00:7a:12'/>
      <script path='/etc/qemu-ifup'/>
      <target dev='virt1'/>
    <input type='mouse' bus='ps2'/>
    <graphics type='vnc' port='5902' autoport='yes' listen='' keymap='sv'/>
Comment 4 Pierre Ossman 2009-01-09 12:29:02 EST
(and for those casual readers, the storage is an LVM volume)
Comment 5 Pierre Ossman 2009-01-09 12:29:47 EST
(In reply to comment #2)
> pierre: also look at bug #479407 and see if any of the suggestions there help

That's this bug ;)
Comment 6 Mark McLoughlin 2009-01-09 13:26:11 EST
(In reply to comment #5)
> (In reply to comment #2)
> > pierre: also look at bug #479407 and see if any of the suggestions there help
> That's this bug ;)

Gah, sorry - bug #475598
Comment 7 Pierre Ossman 2009-01-09 13:45:38 EST
Thanks. I've changed clock source on all guests. Now we'll just have to wait I guess.
Comment 8 Pierre Ossman 2009-01-12 07:45:42 EST
It's been running for three days without problems since I changed the clock source, so this is probably a duplicate of bug 475598.
Comment 9 Chris Lalancette 2009-01-12 07:47:24 EST
OK, I'm going to close it as such.

Chris Lalancette

*** This bug has been marked as a duplicate of bug 475598 ***

Note You need to log in before you can comment on or make changes to this bug.