Bug 479449 - firstboot failed because of a missing 'functions' module
firstboot failed because of a missing 'functions' module
Status: CLOSED DUPLICATE of bug 448098
Product: Fedora
Classification: Fedora
Component: system-config-kdump (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Roman Rakus
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-09 12:41 EST by Jeffery Johnson
Modified: 2014-01-12 19:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-31 00:18:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Firstboot Error Report (336 bytes, text/plain)
2009-01-09 12:41 EST, Jeffery Johnson
no flags Details

  None (edit)
Description Jeffery Johnson 2009-01-09 12:41:35 EST
Created attachment 328574 [details]
Firstboot Error Report

Description of problem:

Problem with firstboot_kdump module.
firstboot fails on installation of Fedora 10.  Error log appears to indicate that there is a missing Module: fucntions

Version-Release number of selected component (if applicable):
Fedora Core 10 installed from DVD as NEW INSTALL

How reproducible:
YES
I have installed on both a Dell Optiplex 745 Desktop and HP Pavilion dv4000 Laptop. Both installs produced the same error.

On the HP Pavilion dv4000, I had initially installed Fedora Core 10 as an UPGRADE from Fedora Core 7 ( choosing UPGRADE instead of NEW INSTALL ), and the error did NOT occur. 

Steps to Reproduce:
1.Install Fedora Core 10 from DVD as NEW INSTALL
2.Selected all initially available repositories and all packages
3.After Install completes, REBOOT
  
Actual results:
Upon REBOOT an error message appears indicating there is a problem with firstboot_kdump module and firstboot did not run because of an error.  Also, indicating that a module called functions could not be found.

Expected results:
Since the error has occurred on multiple computers on multiple attempts, the results on the 2 computers mentioned are expected to be a failing  'firstboot'  program, because of a missing module 'functions'.

Additional info:

copy of contents of firstboot-yjHShz:
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/firstboot/loader.py", line 87, in loadModules
    loaded = imputil.imp.load_module(module, found[0], found[1], found[2])
  File "/usr/share/firstboot/modules/firstboot_kdump.py", line 34, in <module>
    import functions
ImportError: No module named functions
Comment 1 Jaroslav Franek 2009-04-29 08:48:15 EDT
reproduced using Fedora 11 Preview (i386) on Dell Optiplex 270 desktop
Comment 2 CAI Qian 2009-08-31 00:18:50 EDT

*** This bug has been marked as a duplicate of bug 448098 ***

Note You need to log in before you can comment on or make changes to this bug.