Bug 479450 - PDF produced by Firefox Print to File is unusable (blurry) when printed
PDF produced by Firefox Print to File is unusable (blurry) when printed
Status: CLOSED DUPLICATE of bug 450567
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-09 12:43 EST by Kevin R. Page
Modified: 2009-01-29 03:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-29 03:37:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example problematic PDF output produced by Firefox (302.12 KB, application/pdf)
2009-01-09 12:44 EST, Kevin R. Page
no flags Details

  None (edit)
Description Kevin R. Page 2009-01-09 12:43:04 EST
When a page is saved using "Print -> Print to file" as a PDF, if that file is later printed the printed output is unusable - it appears very blurry. At a guess, something is up with the resolution?

However, then the PDF is viewed on screen using evince, it seems to scale fine - go up to e.g. 200% and there's no blurriness (the text looks a bit wonky, but that looks like a font kerning problem).

Similarly if the same page is printed directly (not via print to file) is comes out fine.

An example PDF is attached (the fedoraproject.org homepage). When printed all the text in this PDF is blurry and hard to read, with the copyright text at the bottom so bard it's illegible.

Printing the same page directly results in readable text (the images are missing, but I think that's a different bug!).

A related question/worry: I've a large number of documents saved in this way (as PDF) built up over several months, but having only just tried printing one, are these PDFs permanently broken? Is there anything that can be done to fix them up for printing?
Comment 1 Kevin R. Page 2009-01-09 12:44:37 EST
Created attachment 328575 [details]
Example problematic PDF output produced by Firefox
Comment 2 Kevin R. Page 2009-01-09 12:45:27 EST
Sorry, should have said: firefox-3.0.5-1.fc10.i386
Comment 3 Martin Stransky 2009-01-12 03:03:32 EST
Seems to be better in rawhide (firefox 3.1 beta).
Comment 5 Kevin R. Page 2009-01-28 03:10:26 EST
1) is there a clean way to install 3.1b alongside 3.0.5 or to cleanly revert back to 3.0.5 after testing on F10?

2) can anything be done to fix up PDFs produced with this problem (to which I guess the root question is: what's wrong with them?)
Comment 6 Matěj Cepl 2009-01-28 04:01:58 EST
Yes, just unpack the upstream binary (from http://www.mozilla.com/en-US/firefox/all-beta.html) to any directory and run ./firefox (make backup of your ~/.mozilla directory before that).
Comment 7 Kevin R. Page 2009-01-29 03:37:48 EST
Confirmed that output prints clearly from 3.1b.

Also marking as a duplicate of bug #450567, which I discovered via:
http://cworth.org/cairo/a_chain_of_bugs/

I have a large number of defective PDFs produced by Firefox, so I'd still like to better understand what's wrong with them - ultimately with the hope that they can be fixed up.

*** This bug has been marked as a duplicate of bug 450567 ***

Note You need to log in before you can comment on or make changes to this bug.