Bug 479471 - CUPS never gets the MIME type based on the document name for a single file job
CUPS never gets the MIME type based on the document name for a single file job
Status: CLOSED DUPLICATE of bug 479635
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cups (Show other bugs)
5.3
All Linux
low Severity medium
: beta
: ---
Assigned To: Tim Waugh
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-09 16:28 EST by Opher Shachar
Modified: 2009-01-28 13:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-28 13:07:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CUPS Bugs and Features 3055 None None None Never

  None (edit)
Description Opher Shachar 2009-01-09 16:28:03 EST
Description of problem:
The scheduler never gets the MIME type based on the document name for a single file job. This is because cupsPrintFile*() doesn't send the document filename for single file submissions.

Version-Release number of selected component (if applicable):
1.3.7

How reproducible:
Always

Steps to Reproduce:
1. echo "Not a Postscript file :)" >notpsfile.ps
2. lp notpsfile.ps
  
Actual results:
The error_log shows job was typed as text/plain.

Expected results:
CUPS was to auto-type the job as application/postscript because in `mime.types' there is a rule that `ps' extension is "application/postscript".

Additional info:
I submitted a STR #3055 upstream and it is fixed in v1.3.10 .
Comment 1 Tim Waugh 2009-01-28 13:07:49 EST
Both STR #3055 and STR #3059 are now in bug #479635.

*** This bug has been marked as a duplicate of bug 479635 ***

Note You need to log in before you can comment on or make changes to this bug.