Bug 479481 - KDE applications cannot be launched from konsole after su to another user
KDE applications cannot be launched from konsole after su to another user
Status: CLOSED DUPLICATE of bug 473465
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-09 17:43 EST by Need Real Name
Modified: 2009-01-10 19:29 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-10 13:50:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2009-01-09 17:43:04 EST
Description of problem:

KDE applications cannot be launched from konsole after su to another user.
This appears to be related to the value of DBUS_SESSION_BUS_ADDRESS

Version-Release number of selected component (if applicable):
kdebase-4.1.3-2.fc10.x86_64
coreutils-6.12-18.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. start konsole
2. su fred # any user, root or non-root
3. kwrite
  
Actual results:

kwrite hangs with no output to konsole and no display.
similar results with dolphin, kate
This is not an X11 authentication problem - non-KDE X11 apps have no problem.

Expected results:

kwrite opens in its own window

Fix:

Run this command before launching kwrite:
export DBUS_SESSION_BUS_ADDRESS=

(I found that I could launch KDE applications as another user by switching user with ssh; I compared the environments created by ssh and su, and discovered this fix by trial and error.)

Additional info:

System installed from x86_64 live CD to fresh partition, SELinux disabled, many more RPMs installed with yum.  All components up to date with yum mirrors at
Fri Jan  9 22:25:07 GMT 2009
Comment 1 Rex Dieter 2009-01-09 19:45:32 EST
Nice workaround, but what do you expect us to do with this information?
Comment 2 Need Real Name 2009-01-10 13:04:40 EST
This bug is a regression - this method of launching KDE applications as a different user worked with KDE 3 in Fedora 8 and earlier.

I am not sufficiently knowledgeable about the KDE/DBUS ecosystem to know where exactly the bug lies.  However, I am sure that one of the Fedora maintainers will have that knowledge, and if the bug is considered sufficiently important, he/she will consider fixing it.

My workaround suggests that the problem lies in the interaction between KDE4 and DBUS, but does not come with any greater understanding than that. I thought you'd rather have the information than not have it.

Keith.
Comment 3 Kevin Kofler 2009-01-10 13:50:59 EST
Running GUI apps under su has never been a good idea, I've seen all sorts of problems caused by it in KDE 3, like permissions on Unix sockets used by KDE getting screwed up.

That's what kdesu is for (currently /usr/libexec/kde4/kdesu, we're going to replace the broken KDE 3 /usr/bin/kdesu with a symlink to that in the KDE 4.2 update, maybe already in an earlier update).

*** This bug has been marked as a duplicate of bug 473465 ***
Comment 4 Kevin Kofler 2009-01-10 13:51:26 EST
(Oh, and your workaround is not a fix.)
Comment 5 Need Real Name 2009-01-10 19:29:30 EST
Re #4: fair comment.

Note You need to log in before you can comment on or make changes to this bug.